Highlighted

Move Tool does not move layer when dragging with Wacom tablet

Community Beginner ,
Aug 03, 2010

Copy link to clipboard

Copied

I am using the trial version of CS5 (probably going to upgrade at the end of the trial), and I've only found one thing about it that I don't like more than CS3. This is VERY VERY annoying, and I'm not sure if it's a glitch, or just a preference that needs to be reset:

  When using the move tool, I will move something and it will just snap back to where it originally was. When it snaps back, it might move a few pixels over in the direction I was dragging, but it is definitely not moving to where I want it to go. The only way to get things to move the way I want to is by Free Transform...but it's annoying, when you're trying to design a layout, to have to free transform every element you want to move, first.

I'm guessing that this is a glitch because sometimes it happens and sometimes it doesn't...it's pretty random. I've tried turning Snap on and off, and nothing changes. Any idea how to fix/change this?

~Mike

Message title was edited by: Brett N

Hello,

I think I may have found the culprit. I started using Adobe PS CS 5 Extended the same day I received the Wacom Intuso 4 (about one year ago) and NEVER had a problem until last month when I added Adobe PS CS5 into the application section, see below.

This is the ONLY change that I made to my wacom settings beside the typical button layout.

Screen Shot 2012-03-09 at 3.16.13 PM.png

I just tested this out. I removed the Adobe Photoshop CS5 from the field Application field and restarted Photoshop WITH the tablet plugged in. Now, I can use both the track pad and the tablet. See below:

Screen Shot 2012-03-09 at 3.41.44 PM.png

Just to test my finding, I readded the application BACK to the application field (Photoshop was shut down; pen and mouse three feet away) and modified my settings like I wanted, then I started Photoshop.

At first, I was able to use the track, but as soon as I used the pen, the track pad stopped functioning properly and the "jump back" problem started again.

I only have Flash Player and Wacom in the other field on System Preferences, see below.

Screen Shot 2012-03-09 at 3.19.36 PM.png

In this case it doesn't matter weather the pen is sitting on the tablet or not. Once Photoshop is removed from the Application field of the Wacom settings, the track pad and tablet work in harmony.

I hope this works out for you and helps Adobe/Wacom find a solution/fix to the problem.

Regards,

Brandon

Message was edited by: numeroeins

Message was edited by: numeroeins

Views

94.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Move Tool does not move layer when dragging with Wacom tablet

Community Beginner ,
Aug 03, 2010

Copy link to clipboard

Copied

I am using the trial version of CS5 (probably going to upgrade at the end of the trial), and I've only found one thing about it that I don't like more than CS3. This is VERY VERY annoying, and I'm not sure if it's a glitch, or just a preference that needs to be reset:

  When using the move tool, I will move something and it will just snap back to where it originally was. When it snaps back, it might move a few pixels over in the direction I was dragging, but it is definitely not moving to where I want it to go. The only way to get things to move the way I want to is by Free Transform...but it's annoying, when you're trying to design a layout, to have to free transform every element you want to move, first.

I'm guessing that this is a glitch because sometimes it happens and sometimes it doesn't...it's pretty random. I've tried turning Snap on and off, and nothing changes. Any idea how to fix/change this?

~Mike

Message title was edited by: Brett N

Hello,

I think I may have found the culprit. I started using Adobe PS CS 5 Extended the same day I received the Wacom Intuso 4 (about one year ago) and NEVER had a problem until last month when I added Adobe PS CS5 into the application section, see below.

This is the ONLY change that I made to my wacom settings beside the typical button layout.

Screen Shot 2012-03-09 at 3.16.13 PM.png

I just tested this out. I removed the Adobe Photoshop CS5 from the field Application field and restarted Photoshop WITH the tablet plugged in. Now, I can use both the track pad and the tablet. See below:

Screen Shot 2012-03-09 at 3.41.44 PM.png

Just to test my finding, I readded the application BACK to the application field (Photoshop was shut down; pen and mouse three feet away) and modified my settings like I wanted, then I started Photoshop.

At first, I was able to use the track, but as soon as I used the pen, the track pad stopped functioning properly and the "jump back" problem started again.

I only have Flash Player and Wacom in the other field on System Preferences, see below.

Screen Shot 2012-03-09 at 3.19.36 PM.png

In this case it doesn't matter weather the pen is sitting on the tablet or not. Once Photoshop is removed from the Application field of the Wacom settings, the track pad and tablet work in harmony.

I hope this works out for you and helps Adobe/Wacom find a solution/fix to the problem.

Regards,

Brandon

Message was edited by: numeroeins

Message was edited by: numeroeins

Views

94.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Aug 03, 2010

Copy link to clipboard

Copied

This has happend to me also. I just quit out of Photoshop and restart the program and its goes away.

Also, you can quit out of your program...then hold down the "shift, control, cmd" key to reset all your preferences to the default. This won't affect your "workspace" if you have created one.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 03, 2010

Copy link to clipboard

Copied

Doesn't help


Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advocate ,
Aug 03, 2010

Copy link to clipboard

Copied

This can happen if you drag and the cursor ends up over a panel or other GUI element. Make sure you're not letting go of the mouse when the cursor is over one of these areas.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 04, 2010

Copy link to clipboard

Copied

No, this wasn't the problem either.

I think I found the solution, though...although the solution definitely sounds like this is a glitch in CS5 that needs to be fixed.

I have a Wacom Intuous4 tablet installed. When I try to use the move tool and drag it around with my Wacom mouse, it works fine. When I try to move something around with the trackpad (which I do frequently after I've entered in some keyboard shortcuts), it has the snapback problem.

So I think that maybe the problem is: when you have a tablet installed, the mouse works and the trackpad stops working.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advocate ,
Aug 04, 2010

Copy link to clipboard

Copied

That sounds like a driver problem. See if the trackpad and/or the tablet have updates on their websites.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 04, 2010

Copy link to clipboard

Copied

Updated my drivers, problem still exists.


Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Aug 04, 2010

Copy link to clipboard

Copied

Or you're leaving the pen in to close of proximity of the tablet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 04, 2010

Copy link to clipboard

Copied

The pen is in the holder, which is on the other side of my desk. Don't think that is the problem.... also, when the pen is too close, that prevents the mouse from moving effectively. It does not affect the trackpad, which is the problem.

I'm using a MacBook Pro with the most recent version of SnowLeopard, if that helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 28, 2010

Copy link to clipboard

Copied

I am having the exact same CS5 trackpad drag problem.  It seems as if there is a problem within CS5 that after a period of time it seems to have trouble with the glass touchpad on the macbook pro unibody, and doesnt recognize the difference between the button and the pad, so when you release something you drag it snaps back to it's original position because it thinks you are touching two place on the pad....  that's my best guess.   My work arounds have been quiting the program and reopening seems to fix it, or just using my tablet.   It happens for me with or without the tablet, so the tablet is just a work around.  It is a very consistent problem.

MBP 10.6.4 unibody

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Sep 03, 2010

Copy link to clipboard

Copied

I think we may know what's going on here. Are there docked panels above the area you are trying to drag objects?

This thread describes a similar problem dragging doc to doc or doc to desktop, but the same issue affects moving layers in a document located in the same area.

http://forums.adobe.com/thread/713999?tstart=0

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 03, 2010

Copy link to clipboard

Copied

I thought that might be the problem seeing the link you posted, but unfortunately it's not. I tried doing that in CS5 and it moved into th

at area perfectly when I used the mouse, but same problem when I tried with the trackpad. I also tried moving the layer in the other direction (so it wasn't overlapping the area), but it did the same jerk-back problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Engaged ,
Sep 03, 2010

Copy link to clipboard

Copied

>I think we may know what's going on here. Are there docked panels above the area you are trying to drag objects?

I found this to be true, dragging within the same restricted area below expanded panels doesn't work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 03, 2010

Copy link to clipboard

Copied

Would that explain why it will drag fine with the tablet but not the trackpad?

Also the problem goes away after quitting and restarting?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Engaged ,
Sep 03, 2010

Copy link to clipboard

Copied

drag within a document over the "protected" area doesn't work for me with either tablet or mouse, and restarting PS has no effect.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 13, 2010

Copy link to clipboard

Copied

I don't believe this is the problem in my case. Everytime I restart photoshop the problem goes away, then after a certain amount of time the problem recurs. I don't have anything protected or docked. I am using a tablet to draw, and I occasionally use the text tool to label something, I can also move the layer with the tablet but not the trackpad. So would something be locked for the trackpad and not the tablet?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 03, 2012

Copy link to clipboard

Copied

I've had this problem a million times and the pen location never mattered. However this last time it was sitting next to the tablet, and when I moved it the problem went away.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 04, 2012

Copy link to clipboard

Copied

InsomniaGFX, was the tablet close to a monitor/Loudspeaker? Anything that could cause an interference?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 20, 2010

Copy link to clipboard

Copied

I have exactly the same problem. I´m using a full version of cs5, educational, but still. Very annoying. I´m using a wacom too usually, but it´s switched off and in my bag, so can´t be the pen or whatever..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 24, 2010

Copy link to clipboard

Copied

I'm experiencing the same problem as described here and I too have a macbook pro unibody and a wacom tablet.  I don't know who's at fault but I can't help think it's Adobe seeing that before upgrading to CS5 from CS4 I didn't experience this problem but had the same computer and tablet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 24, 2010

Copy link to clipboard

Copied

i also seem to be able to select transform object and then I can move the object with the trackpad when this problem occurs.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 27, 2013

Copy link to clipboard

Copied

Thank you, that's a nice workaround! I have the same problem the poster had - randomly, the trackpad stops working with the move tool and objects snap back to where they were when I try to move them, even when my Wacom Bamboo and stylus are across the room in my computer bag! (Macbook Pro unibody, OS 10.6.8). Restarting helps but then the problem returns. Fine when I've got my tablet plugged in because the tablet will work with the move tool, but, like right now when it's not plugged in and I don't want to restart PS, I'm SOL - saved by your suggestion! Interesting that "scott w" with an Inutos tablet had the same problem (his solution didn't work for me).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Aug 27, 2013

Copy link to clipboard

Copied

Do you have the wacom latest driver installed? (what version of the driver are you running?)

Did you try this solution that worked for other users: http://forums.adobe.com/message/4256189#4256189

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 27, 2013

Copy link to clipboard

Copied

I have just started experiencing this with Photoshop CC, Mac Pro, intuos 4.  Command-T is not a good solution because I don't want to move these particular objects off the pixel grid, though still want the ability to move off the pixel grid sometimes.  Updating to the newest intuos driver doesn't help. Command+ Command- seems to temporarily fix the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Engaged ,
Oct 01, 2013

Copy link to clipboard

Copied

Jeffrey, what solution specifically are you pointing to?

What stood out for me was this post from 16 months ago:

107. Brett N,

    

  Mar 12, 2012 11:53 AM    in reply to numeroeins

I'm currently in communication with some folks from Wacom. We are able to reproduce the issue (both at Adobe and Wacom) and are currently investigating.

So, what have you all come up with? What's the fix?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 03, 2010

Copy link to clipboard

Copied

I have found the same thing using a Mac Pro and their new trackpad. The Wacom Tablet allows movement but the trackpad doesn't. It must be a Mac interface problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 03, 2010

Copy link to clipboard

Copied

I really think it has something to do with a driver or something, over time failing to separate the area over the button as just a button when you click (since there whole pad is a trackpad) and Photoshop somehow thinks you are touching two places at the same time and snaps back to your old position. That's my theory.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Oct 03, 2010

Copy link to clipboard

Copied

This occasionally happens to me with my MacPro and Inutos tablet. With the move tool or transforming a layer.

How I fix it... Undo. Then Command-+ (plus) followed by Command-- (minus). Then the tool will act as expected.

Something to do with the video card not getting correct signals or something when the app has been backgrounded and brought forward.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 06, 2010

Copy link to clipboard

Copied

I also find that I can use the arrow keys as a workaround moving something into place.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 24, 2010

Copy link to clipboard

Copied

[SW] is correct, by undoing and Command + then Command - corrects this "bug". Somehow this corrects this. Maybe it is something with the video card caching. CS4 was similar to other types of bugs that this fix also has corrected.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 03, 2011

Copy link to clipboard

Copied

Maybe in some instances, but Command + then Command - does not correct the bug for me. I find the bug more often happens when using certain fonts.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 27, 2013

Copy link to clipboard

Copied

Yes, the arrow keys work, but what a waste of time!!! Good to know about that but the Free Transform (command t) solution is more efficient.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 27, 2013

Copy link to clipboard

Copied

To pro dosya: what is the web link you posted - I ain't clicking on it because that seems fishy to just post a link and am considering reporting it. please write what it is.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 27, 2013

Copy link to clipboard

Copied

Agreed, CMD+T is more efficient. More efficient still would be the tools operating as they should. My tablet has been in a drawer for months now thanks to these issues, and I just picked up a new client that is going to require some serious hand drawing. Odd that at the same time this thread has resurrected.

These issues hardly seem insurmountable. I just don't believe it to be a priority on Adobe's or Wacom's part. So here we sit...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...