Highlighted

My numbers and punctuation glitching on Photoshop. Help?

Community Beginner ,
Aug 27, 2012

Copy link to clipboard

Copied

When typing numbers or punctuation on Photoshop CS6, they always glitch and go back to the beginning of the sentence and can't be made to go after the letters. I can't think of anything that's wrong. Please help!

Adobe Community Professional
Correct answer by Jeff_Arola | Adobe Community Professional

in photoshop are your type options under Preferences>Type set to Middle Eastern or East Asian?

Topics

How to

Views

190.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

My numbers and punctuation glitching on Photoshop. Help?

Community Beginner ,
Aug 27, 2012

Copy link to clipboard

Copied

When typing numbers or punctuation on Photoshop CS6, they always glitch and go back to the beginning of the sentence and can't be made to go after the letters. I can't think of anything that's wrong. Please help!

Adobe Community Professional
Correct answer by Jeff_Arola | Adobe Community Professional

in photoshop are your type options under Preferences>Type set to Middle Eastern or East Asian?

Topics

How to

Views

190.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Aug 28, 2012

Copy link to clipboard

Copied

http://forums.adobe.com/thread/419981?tstart=0

Please explain in more detail.

Boilerplate-text:

Are Photoshop and OS fully updated and have you performed the usual trouble-shooting routines (trashing prefs by keeping command-alt-shift/ctrl-alt-shift pressed while starting Photoshop after making sure all customized presets like Actions, Patterns, Brushes etc. have been saved and making a note of the Preferences you’ve changed, 3rd party plug-ins deactivation, system maintenance, cleaning caches, font validation, etc.)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 28, 2012

Copy link to clipboard

Copied

Right. If I was trying to write "The year 1995", when typing the first number, it would automatically go to the front of the text and look like "1995 The year". The same rules apply for any punctuation I use at the end of sentences.

Also, if I was trying to highlight all of the text, what would be highlighted would either be "1995", "The year" or the space inbetween "1995" and "The". It isn't possible to highlight every word in the text. Another thing is that the blinking line where the text should type is always at the beginning of the text unless I hold the right arrow key.

Please ask any questions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Aug 28, 2012

Copy link to clipboard

Copied

That happens when using the Type Tool to create Point Type and Paragraph Type both?

Have you trashed the prefs yet?

You could also try checking out:

http://helpx.adobe.com/photoshop/kb/troubleshoot-fonts-photoshop-cs5.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 28, 2012

Copy link to clipboard

Copied

"That happens when using the Type Tool to create Point Type and Paragraph Type both?"

Yes, both.

"Have you trashed the prefs yet?"

I just did so but it came to no avail.

I'll try the more time cosuming things on the list later when I have more time but nothing worked yet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Aug 28, 2012

Copy link to clipboard

Copied

Sounds strange indeed.

Are other programs affected?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 28, 2012

Copy link to clipboard

Copied

Every other program seems fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Aug 28, 2012

Copy link to clipboard

Copied

It seems unlikely, but are any Scripts linked to events in File > Scripts > Script Events Manager?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 28, 2012

Copy link to clipboard

Copied

Hi! did you reset the type tool (right-click the tool on the option bar)

Does it happen with all fonts, or just one?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 28, 2012

Copy link to clipboard

Copied

No scripts are linked to events.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 28, 2012

Copy link to clipboard

Copied

in photoshop are your type options under Preferences>Type set to Middle Eastern or East Asian?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 28, 2012

Copy link to clipboard

Copied

"did you reset the type tool (right-click the tool on the option bar)"

No, but I just did and it didn't work.

"Does it happen with all fonts, or just one?"

All fonts.

Something I just noticed was when the text starts centred on the right, the blinking line that should be telling me where my text will be coming up moves backwards when I press the spacebar; then when backspacing, the line goes fowards.

Sorry if that last sentence didn't make sense...it's early.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 28, 2012

Copy link to clipboard

Copied

You got it! It was set to Middle Eastern and changing it to East Asian fixed the problem. Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 28, 2012

Copy link to clipboard

Copied

It's strange that resetting the photoshop cs6 preferences didn't cure that if your using an version of photoshop not localised for a middle eastern region.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 31, 2016

Copy link to clipboard

Copied

So what's the correct preference?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 01, 2016

Copy link to clipboard

Copied

Fix originally submitted  by : Xenil Nov 6, 2013 1:52 PM …


"NOTE: THIS DOES INCLUDE HAVING MIDDLE EASTERN SET, BUT ISN'T THE FIX ITSELF!

1. Go to 'Type' through the menu, or (preferences on mac) and make sure type set is set to Middle Eastern.

            There, wasn't so hard, was it? =]

2. Now, do this:

Step2.png

3.

Step3.png

4.

Step4.png

5. This may set back and forth if you have a certain text layer selected, so make sure you're doing this independently of any layers.

Hope this helps."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 01, 2016

Copy link to clipboard

Copied

Why is it I do not have the bottom part of the dialog box in my Photoshop? I don't see any option to turn on either in the Paragraph panel itself. I can't choose what your pointing to with your arrows in point 4 of your graphic. I'm on Creative Cloud 2015. This problem has been driving me crazy. Screen Shot 2016-04-01 at 10.09.19 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 06, 2016

Copy link to clipboard

Copied

This is what I do to see those extra options in the Paragraph Panel:

I have "Middle Eastern" set in Preferences/Type, but every so often the extra options in the Paragraph panel disappear - not sure why, and then the right-to-left issue happens when I type the "&" or other punctuation. It drives me crazy.

I go back to Preferences/Type... and select East Asian, since Middle Eastern is already selected but not showing my extra options in the panel... then I quit Photoshop, reopen and I see the extra Paragraph options to fix the RTL issue.

Hope that helps!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Engaged ,
Jun 25, 2017

Copy link to clipboard

Copied

Thanks again...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 06, 2019

Copy link to clipboard

Copied

Thanks still working in 2019!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 25, 2019

Copy link to clipboard

Copied

Thank you so much. You just f*cking nailed it. It would take me forever if I would look for it myself.  I truely appreciate it. Tata!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 29, 2020

Copy link to clipboard

Copied

How do I change the default type to Asian?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 15, 2013

Copy link to clipboard

Copied

I still have the problem that all punctuation is appearing on the left side of my text. What makes most of my documents useless.

Recreating them from scratch is NOT an option due to high complexity.

I am Cloud member and Photoshop is up to date.

What is the solution to fix that problem now?

  • I tried switching between Middle Eastern and East Asian text engines.
  • I tried to delete styles, resetting paragraphs, etc
  • I deleted Photoshop preferences

Nothing helped yet.

Punctuation always appears on the left side instead after text.

What's also strange is that after deleting the preferences, creating a new document and writing text - the text is by default aligned right instead left.

Does that mean my documents, which I have built up over years/months, are irreversibly skrewed?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 16, 2013

Copy link to clipboard

Copied

Highlight your text and select 'Paragraph'.

Select the icon in the very top right corner so a menu pops open.

Select:

Adobe Single-line Composer

and

Right-to-Left Paragraph Direction

That should do it!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 09, 2013

Copy link to clipboard

Copied

My photoshop, also cloud just started this today and NOTHING seems to work. I just tried this trick...still doing it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 29, 2013

Copy link to clipboard

Copied

Hi guys!

I use CC 14.0 and I can't seem to figure out the type tool. it types right to left and i tried all the solutions above. In the paragraph panel there's no left to right or right to left option and all the other options that may work out for me are greyed out and i can't select them.

What should I do next?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jul 29, 2013

Copy link to clipboard

Copied

You have your Text Engine in Photoshop set to "Middle Eastern". 

Go back to Photoshop Preferences and change the Type Engine Option to "East Asian"  (don't ask me why Adobe has chosen that terminology ).

PS_13_Type_Prefs.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 29, 2013

Copy link to clipboard

Copied

Thanks a lot station_two!! This fixed my issue but now I have a problem with symbols like " or } as they seem to move to the begining of the line randomly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 06, 2013

Copy link to clipboard

Copied

Hey there.

I've been browsing and looking for an answer everywhere in order to fix my problems.

I think I've found a solution, but just to clarify, this was my problem:

If I was to type the this:

Cat, dog and mouse were smoking it all up.

The sentence would come out, like this:

.,Cat dog and mouse were smoking it all up

Or something alike, anyway.

But I've fixed it with a click of a button, or two.

This is what you do:

NOTE: THIS DOES INCLUDE HAVING MIDDLE EASTERN SET, BUT ISN'T THE FIX ITSELF!

1. Go to 'Type' through the menu, or (preferences on mac) and make sure type set is set to Middle Eastern.

            There, wasn't so hard, was it? =]

2. Now, do this:

Step2.png

3.

Step3.png

4.

Step4.png

5. This may set back and forth if you have a certain text layer selected, so make sure you're doing this independently of any layers.

Hope this helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 29, 2014

Copy link to clipboard

Copied

I don't see that option in my photoshop CS6 (Version 13 x64), not Cloud. But, I am experiencing the same exact thing you mention. What are those buttons labeled. Any idea where I can find it in the non-Creative Cloud version of the software?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 06, 2014

Copy link to clipboard

Copied

In order to get the option for "left to right" and "right to left" you have to click Type -> Language Options -> Middle Eastern Features and it will add a row of options to the Paragraph panel. This solved it for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 03, 2015

Copy link to clipboard

Copied

Thanks @xenil for the visuals and explanation - this fixed the issue for me

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 03, 2016

Copy link to clipboard

Copied

Thank you very much, this helped me for the same problem

www.renovaweb.ca

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Engaged ,
Jun 11, 2017

Copy link to clipboard

Copied

Thanks so much, Middle Eastern Features were correct so I followed your second option--clicking on the left r paragraph icon. AWESOME!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 25, 2017

Copy link to clipboard

Copied

Xenil, Thank you!!!!

It really helped me because I needed the Text Engine set to Middle Eastern (damn RTL Hebrew...)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 27, 2017

Copy link to clipboard

Copied

I completely forgot about this age-old post of mine somewhere. I'm glad someone re-posted it into this forum and that it helped some of you. I've not looked into any of it further so for those that this doesn't work, I'm sorry I have no clue. Just keep browsing forums I suppose.

Cheers,

Xenil.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 12, 2017

Copy link to clipboard

Copied

THANK YOU!!!  Finally fixed it!!!  Been driving me nuts for a month!!  Been inserting punctuation in it's own text box to bypass!!

This answer should be all the way upvoted!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 13, 2018

Copy link to clipboard

Copied

THANK YOU

THANK YOU

THANK YOU

yes this worked!!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 30, 2019

Copy link to clipboard

Copied

Fuuuuuuukccccc that solved my problem. Cheers dude

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 05, 2016

Copy link to clipboard

Copied

I had the same problem and this is the answer that worked for me.

Thanks ta2laroo

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 01, 2014

Copy link to clipboard

Copied

I've got the solution:

- Type > Panels > Paragraph Styles Panel.
- Create new (Create new paragraph style), the button left to the delete option.

- Double click on the new "Paragraph Style +1"
- Make the changes you want and save

- Use the new paragraph style ("Basic Paragraph" is the one making problem)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 19, 2016

Copy link to clipboard

Copied

This actually worked for me. I dont know why adobe doesnt let you delete the Basic style. Dumb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 05, 2014

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 13, 2014

Copy link to clipboard

Copied

Carl4's link did the trick. Nothing else in this thread worked. Thanks Carl!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 08, 2015

Copy link to clipboard

Copied

Yes! Carl's explanation worked!  TY so much.  How awful of Adobe to release it this way --even on the latest upgrade it isn't fixed.  Ridiculous.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 02, 2014

Copy link to clipboard

Copied

Looks like this option is gone in cc 2014

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 12, 2014

Copy link to clipboard

Copied

I had this problem too and I just selected

Type > Language Options > Left-to-right Character Direction.

Hope this helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 22, 2015

Copy link to clipboard

Copied

This worked for mine, thanks a bunch.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 13, 2017

Copy link to clipboard

Copied

nice idea

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 09, 2014

Copy link to clipboard

Copied

I find no option to change this to Middle Eastern...please help...really annoyed

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 09, 2014

Copy link to clipboard

Copied

Photoshop>Preferences>Type



psfa.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 21, 2014

Copy link to clipboard

Copied

Carl's option worked for me as well. Thanks for a glitchy program Photoshop . I hope they correct this with a patch so people won't have to use this odd workaround! Good luck everyone.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 18, 2015

Copy link to clipboard

Copied

Fixed it for me even with Photoshop CC 2015 1.01

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 14, 2015

Copy link to clipboard

Copied

Thank you so much for this. I've had my brain wrapped around this problem for over an hour trying all sorts of diagnostics recommended by folk. You're a life saver.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 13, 2015

Copy link to clipboard

Copied

Thanks Carl4!! This is the link that saved me as well, I tried everything else and nothing had worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...