Open CL greyed out - Catalina

Community Beginner ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

Hi

Probably due to an update of Creative Cloud (?), Open CL cannot be activated anymore. The result is that Plugins such as Luminar 4 by Skylum do not work properly anymore. The result they are sending back to Photohop appear black. This is the case one more than one Mac running latest version of Catalina (10.15.7) – and it is a pure nightmare. I was hoping that Adobe would be able to fix GPU issues - and am quite disappointed. Hope that it will be fixed soon again. Fortunately it is still working ith a MacPro and Mojave...

TOPICS
Bug, Mac, Problem or error

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 06, 2021 May 06, 2021

Copy link to clipboard

Copied

This is being widely reported.

Reinstall a previous version of Photoshop from the CC desktop app for now.

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 06, 2021 May 06, 2021

Copy link to clipboard

Copied

Thanks - I have downgraded this way to 22.3.0 and 21.2.6 but none of these steps worked. It looks as if there are some changes under the hood with Creative Cloud as well inhibiting OpenCL with Catalina.

Maybe you have a good idea for solving this - or which version should be working properly for now?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

Go to preferences/performance under advanced settings and make sure "Use Open CL" is off.

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

Thanks - it does not help. It was Off – since it was greyed out and off. If have deleted the preferences and interestingly I was able to switch it on again, which is what I did. Then I checked again but it did no change anything, so I switched back to the old prefs, Open CL turned off and greyed out... 😞

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 14, 2021 May 14, 2021

Copy link to clipboard

Copied

Hi

In 22.4. I can now actvate Open CL. That's fine. However the results from the Lumianr 4 Plugin are still black.

So at least this issue is not solved - and I would say that Adobe should do their homework because Luminar 4 was fine, did not change and what was changed was the Photoshop updates...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 14, 2021 May 14, 2021

Copy link to clipboard

Copied

Have you checked for any updates from Luminar? Adobe does not manage third party plugins. Its the plugin manufacturer's responsibility to keep compatible with software updates.

It's like complaining that your after market radio that you added to your 2020 car now doesn't fit since you have a 2021 car model.

If your Luminar plugin worked in XX version of Photoshop and now does not - the answer is to reinstall the last PS version in which it worked until Luminar updates their plugin.

Kevin Stohlmeyer Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 15, 2021 May 15, 2021

Copy link to clipboard

Copied

LATEST

Thanks Kevin

I vcan see your point and I agree to a certain degree. I have however switched back to older versions of Photoshop, which worked fine with Luminar 4 – but do not do anymore now. So, what are the variables:

- Adobe Creative Cloud application - does it have an effect on how an application is working/GPU?

- Photoshop prefs - they always get replaced - anything there we have lost here?

- Apple Catalina: different GPU management due to a recent Security update?

We have informed Skylum (Luminar 4) and they have heard about this issue from several users.

Hopefully they will find a solution, that is compatible to the most recent versions of Catalina and Photoshop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines