Pen Tool issues

Community Beginner ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

The pen tool has a load of issues I've never seen before, has been happening over the last 2-3 weeks. I have not changed any settings. Problems:

 

  1. When creating a new path, I place the first node down. When clicking for a second, a path is not drawn between them (just nodes shown). I have found a temporarly work around where I select 'Shape', draw a couple nodes, then switch back to 'Path' where the conecting path shows again. 
  2. On occasion, when aiming to place the node and then drag it to create a curve, the node doesn't show a handle but just sticks to my on screen pointer. No handles are shown. 
  3. The worst case of this creates an undesirable flickering (brightness changes) of the image and the pen tool behaves like example 2. 

 

These issues happen with a degree of randomness, sometimes after loading a second or third large image (12,000x800px) into a session (the previous images not even open any more), but occasionally on the initial opened image with a new session of PS. Sometimes a PS restart will fix it, sometimes I have to restart the computer. It's very frustrating for such a previously reliable tool.

 

I am running a 2019 MBP - 2.4GHz 8-core i9, 32GB, with the AMD 5500 8GB card. I always do the latest CC updates.

 

 

TOPICS
Bug, Performance, Problem or error

Views

115

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Apr 06, 2021 Apr 06, 2021
Hi This is a reported bug. Many of us have reverted to 22.2 until Adobe releases a patch for this. The workaround is to keep a work path open, then the Pen tool will work on your named paths.   Please make your comments to Adobe on this thread on their feedback forum: https://feedback.photoshop.com/conversations/photoshop/photoshop-2230-pen-tool-not-working-as-it-should/6048a2bf7824794abde8b9c7   ~ Jane

Likes

translate

Translate

Translate
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

Hi

This is a reported bug. Many of us have reverted to 22.2 until Adobe releases a patch for this. The workaround is to keep a work path open, then the Pen tool will work on your named paths.

 

Please make your comments to Adobe on this thread on their feedback forum:

https://feedback.photoshop.com/conversations/photoshop/photoshop-2230-pen-tool-not-working-as-it-sho...

 

~ Jane

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

Thank for the rapid response, Jane!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

You're welcome, @Eano !

~ Jane

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines