Permanently disable option to link smart objects to the cloud in Photoshop CC

Community Beginner ,
Mar 27, 2019 Mar 27, 2019

Copy link to clipboard

Copied

Hi,

I was wondering if there was a fix so that nothing is ever linked in my layered Photoshop file to the cloud. I want all smart objects to always be embedded when they are pulled in to my document. Is there a setting which will allow this permanently?

I have tried searching for this subject but couldn't find it. Apologies if it has been previously answered.

Thanks.

Views

4.0K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Mar 27, 2019 Mar 27, 2019
You have option to embed linked smart object layer(s), are you aware of that option? It is available in context menu (right click menu) and from Layer > Smart Objects > Embed All Linked.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Mar 27, 2019 Mar 27, 2019

Copy link to clipboard

Copied

Can you please describe:

when they are pulled in to my document

You are pulling images, documents from where? Libraries panel, desktop...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 27, 2019 Mar 27, 2019

Copy link to clipboard

Copied

Apologies, I wrote this in a hurry.

When pulling smart objects into a photoshop document and they are opened by others, there is a missing link symbol. I know how to correct this, but I want to know if there is a setting where all smart objects inserted are permanently embedded? These objects come from anywhere except the library. Desktop, work server, etc.

Thank you

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 27, 2019 Mar 27, 2019

Copy link to clipboard

Copied

You have option to embed linked smart object layer(s), are you aware of that option? It is available in context menu (right click menu) and from Layer > Smart Objects > Embed All Linked.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 27, 2019 Mar 27, 2019

Copy link to clipboard

Copied

Hi Bojan,

Thank you for your answer. I am award of how to embed all smart objects, however I wanted to know if there is a setting in preferences or similar which means that all smart objects are always going to be embedded when dragged in and never linked to libraries. I don't want to have to manually embed every time for a document. I am pretty sure there was a way to do this when Photoshop first introduced linking smart objects to the cloud?

Thanks.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 27, 2019 Mar 27, 2019

Copy link to clipboard

Copied

I believe you are aware of two options to place Embedded and Linked objects. Dragging image from outside application should create embedded object.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 27, 2019 Mar 27, 2019

Copy link to clipboard

Copied

There isn't option in preferences to always create embedded smart object layer. I have problem with platform and I must reply like this, it does not allows me to edit answer.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 27, 2019 Mar 27, 2019

Copy link to clipboard

Copied

Thank you Bojan, I was pretty sure this wasn't the case before but I might be mistaken. Unless there is an alternative, I will mark this as correct!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 23, 2019 Oct 23, 2019

Copy link to clipboard

Copied

It should be noted that there is a check box in the lower portion of the dialog box that appears when you paste something from illustrator (smart object, pixels, etc) that asks if you want to add to your CC library. Simply unchecking that box should prevent your smart object from linking to CC and therefore will auto-embed. 

 

I know you already marked this correct, but it wasn't clear to me from what I read that this solution was clearly presented.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2021 Apr 08, 2021

Copy link to clipboard

Copied

That's the answer I was looking for.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines