Photoshop 2018 can't be set as default "open with" for any file type

Community Beginner ,
Nov 21, 2017

Copy link to clipboard

Copied

I installed CC 2018 yesterday. When I try to set Photoshop as default program to open JPG, PNG, etc., the program is not listed under Recommended Programs. When I choose Other Programs > Browse and navigate to PS 2018, select and hit open, nothing happens -- it's not added to the list of other programs.

If I go to Control Panel > Set Default Programs, NONE of the Adobe CC 2018 programs are available to select as default programs.

Please help!

TOPICS
Problem or error

Views

21.0K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Community Beginner , Dec 20, 2017
graham_geary Community Beginner , Dec 20, 2017
This issue might have resolved itself: after dragging the problem file types into Photoshop to open them, eventually Windows learned to associate Photoshop 2018. For example after dragging JPGs into Photoshop a few times, all of a sudden Photoshop appeared as a possible default program for JPGs. I guess this issue is resolved for me, sort of? Do you get the same results if you drag files in a few times?

Likes

Translate

Translate
Jump to answer Jump to answer
Community Beginner ,
Nov 17, 2018

Copy link to clipboard

Copied

Adobe, has recognized this as a fault in their application.  After struggling for hours with their nightmarish support they sent this response. "Issue you are facing with Photoshop CC is known issue and you need to wait till next update and mean while you can do it manually.  Hence We are closing your case. If you face any other feel free to contact Adobe.

Regards

Adobe Support"

By "manually' they mean, right click on the file and choose "Open With" and select Photoshop.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Nov 21, 2018

Copy link to clipboard

Copied

So what has worked for some people is right click jpg file---open with---  choose another app--more apps-- then browse to the photoshop.exe file in Program Files and select it. Did not work for me. I have two identical Win10/Photoshop systems one on my desktop and one on my laptop. My desktop works absolutely fine but having tried all the suggested solutions I have not come right on my laptop. My next step is to find out what registry corrections I can make--if anyone can help with that on Win 10--there is a VISTA one out there but it's different!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Dec 19, 2018

Copy link to clipboard

Copied

Hip Hip Hooray! Microsoft has resolved the issue with a new patch

My IT department told me that they received word from Microsoft that it was deploying a patch, beginning this week, that fixes this problem. Hopefully this will resolve this issue for all of us.

Apparently the problem was caused by a conflict generated by Microsoft Edge, which tries to claim association to nearly all graphic and image file types.

Thank you all for your advice and suggestions.

Eric

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 19, 2018

Copy link to clipboard

Copied

Sorry to burst the bubble, but this has been a general problem ever since Vista and Photoshop CS3. I speak from experience, i*ve been around the forums in all that time and it happens with every new version. Install a new version > uninstall old version > file associations broken and can't be restored to new version. Regular as clockwork.

There was, however, a small subset of related issues caused by a recent Windows 10 update. This is likely what they're fixing now, and it might take care of a few of the people affected by this.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Dec 22, 2018

Copy link to clipboard

Copied

Not sure what you mean when you report that dragging in files.  If I open a .jpeg or a png I get rhe same result, the default won't c hange.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Apr 05, 2020

Copy link to clipboard

Copied

This Worked for me:

 

Close Photoshop. Right click on any photoshop file and go to Properties.

In the General Tab where it says "Open With:" click the Change... button.

Set to the Photoshop.exe.

Double click the .psd file to open.

 

If you go back to the Windows Settings you will see that .psd has magically changed to Photoshop

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 11, 2020

Copy link to clipboard

Copied

This solved my issue instantly. I had the issue described above because i had cc2018 and cc2020 installed at the same time and removed 2018 thinking that would solve the problem of opening in the wrong program but it didn't. now even jpeg and other photo files have cc2020 in the "open with..." context menu! Koodos brother! 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 14, 2020

Copy link to clipboard

Copied

I am having the same issue.   When I open a file and go to General and click change under opens with, photoshop isn't even an option.  I have no idea what to do.

 

Any thoughts?

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 15, 2020

Copy link to clipboard

Copied

You have to choose "more apps" and then scroll to bottom and click "look for another app on this PC" then navigate to Photoshop.exe (usually C:\Program Files\Adobe\Adobe Photoshop 2020) double click Photoshop.exe and the problem should be fixed for all .PSD files and also Photoshop 2020 should now appear in context menus for jpeg, and other image files.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 01, 2021

Copy link to clipboard

Copied

Dethrat, you solved a frustrating problem. Once I associated the .PSD file to Photoshop 2021 in the General Tab, it appeared as a choice for other file types, such as .jpeg and .tiff. Oddly, it didn't do so for .png automatically, but associating it in the Properties tab fixed that as well. The really annoying thing is that Windows 10 doesn't allow you to associate the file type with a program it doesn't want to recognize, such as Photoshop. And why would I ever want to go to the Microsoft store?

Thanks again. This solved my problem. Now I can just click on an image file and PS 2021 opens it automatically.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more