Highlighted

Photoshop 2020 trial does not load and shows a blank screen.

New Here ,
Oct 11, 2020

Copy link to clipboard

Copied

hi, I just got today the 7 days free trial for photoshop and when I open it stays forever in the picture below I don't know how to fix it and I need it immediately please help me.

Screen Shot 2020-10-11 at 14.07.17.png

TOPICS
Bug, Crash or freeze, Mac, Problem or error

Views

54

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Photoshop 2020 trial does not load and shows a blank screen.

New Here ,
Oct 11, 2020

Copy link to clipboard

Copied

hi, I just got today the 7 days free trial for photoshop and when I open it stays forever in the picture below I don't know how to fix it and I need it immediately please help me.

Screen Shot 2020-10-11 at 14.07.17.png

TOPICS
Bug, Crash or freeze, Mac, Problem or error

Views

55

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 11, 2020 0
Adobe Employee ,
Oct 12, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry that Photoshop 2020 does not load and shows you a blank screen.

 

To start with, please sign out of the Creative Cloud dekstop app and sign back in. See https://helpx.adobe.com/download-install/kb/activate-deactivate-products.html 

 

If that does not help, here are couple of other troubleshooting steps things to try:

1) Reset the Photoshop Preferences file by holding Option+Command+Shift (Mac OS) as you start Photoshop. A new preferences file with default settings will be created.

2) If the issue remains try disabling GPU support in the Preferences> Performance by unchecking 'Use Graphics Processor,' and then restart Photoshop.

 

3) If you do not use the Home screen or the new New Document dialog, you can disable them.

Go to Edit (Windows) / Photoshop (macOS) > Preferences > General.

In the Preferences dialog, select the Use Legacy New Document Dialog and deselect the Auto-Show the Home Screen option.

 

Let us know the outcome.

 

Thanks,

Akash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
New Here ,
Oct 14, 2020

Copy link to clipboard

Copied

Sadly i tried every single one of them and neither work i was going to buy photoshop but unfortunatly i dont wanna waste my money of somethink that will not work thanks for your replie

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 14, 2020 0