Photoshop 22.3.1 lagging when zooming or scrolling

New Here ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

Hello,

 

My PC specs:

AMD Ryzen 9 5950X

NVIDIA RTX 3090 FE (24 GB GDDR6X VRAM) Driver Version 466.27 (latest)

32 GB DDR4 RAM

ASUS ROG Crosshair VIII Dark Hero mobo

Windows 10 64-bit Version 10.0.19042 Build 19042

Photoshop 22.3.1

 

About a year ago (on my previous PC) I noticed that Photoshop was overall really laggy when doing just about anything - changing brush size, zooming, scrolling, you name it.  I wasn't using it much at the time but whenever I had to it was a miserable experience.  One of the things that I was looking forward to with my new PC was that hopefully the issue with Photoshop would be solved, as I had been planning to use it quite a bit more on my new PC.  Well, now I have a top-of-the-line PC with a monster of a GPU and Photoshop can't handle zooming and scrolling.  Whenever I use alt and my mousewheel to zoom, there is at least a second to 2 second lag before the zoom happens.  After this lag, zooming will work generally lagless (although it still doesn't feel entirely smooth) for a little while or until I scroll left or right.  If I now use ctrl + mousewheel to scroll left/right, there is the same period of a second to 2 second lag before the scroll happens.  Then the scrolling will be lagless (again, still not entirely smooth though) for a little while or until I zoom again.  So basically I have to encounter this period of a second to 2 second lag every time I want to switch between zooming or scrolling, or if I don't do either for awhile.  It is very frustrating.

 

I just started using Photoshop on this new PC so I don't know if this is the only issue, it is just the first one I immediately noticed and went online to see if there were any solutions.  I was using the previous version of Photoshop and encountering these same issues, which prompted me to check for updates and update to the latest 22.3.1.  I need to experiment with different settings to see if anything helps this, but I feel like this really shouldn't be an issue at all, especially with the hardware I have in this PC.

 

If anyone has any suggestions or is encountering the same issue, please let me know

 

Thanks!

 

TOPICS
Bug, Performance, Problem or error, Windows

Views

260

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation