Photoshop CC 2015 is so slow it is unusable on my system

Contributor ,
Jun 17, 2015

Copy link to clipboard

Copied

I have no idea what is wrong here but this version of PS its horribly slow.

Here is a video i just captured about this issue:

http://cl.ly/2W0P381A1G1y/60fps-PSCC2015-slow.mp4

There is not difference with GPU enabled, there is no difference if I have or not rules enabled. I never experienced something like with with CC 2014.

MacPro with 12 cores and 64GB RAM

Its there something I could do to fix this?

We have a suggestion we'd like affected people to try out.

If you have slow menus or laggy commands, can you try turning OFF font preview (Type>Font Preview Size = None)?

(If it was already off, and you still have slow menus or laggy commands, we'd like to know that as well.)

Thanks.

Views

127.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Aug 17, 2015

Copy link to clipboard

Copied

Adobe, let us know when this is fixed. My machine flies through PS 2014 no problem...but take almost 30 SECONDS to open the freaking effects panel: http://screencast.com/t/jlrOuqrm this is insanse and so frustrating!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 17, 2015

Copy link to clipboard

Copied

Also, Disabling font previews, library panels, changing history states etc – none of it worked for me. Only going back to 2014 did the trick.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 17, 2015

Copy link to clipboard

Copied

Same slowness here running NMP 2013 6 core 32Gb Ram.

Spinning wheel of death for minutes when saving.

Illustrator, photoshop and indesign became almost unusable.

Turned off Wi-fi and bingo! That restored a lot of the speed and stability.

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 17, 2015

Copy link to clipboard

Copied

Yep, I posted on here about two weeks ago and whaddya know, Photoshop is back to complete crawl today. Not only do I lose valuable time just to the lagging application, but I keep creating errors and problems because the app stalls for so long that I end up clicking and dragging things that I'm not intending too.

I really do believe it has something to do with the fact that we're all connected to the Adobe monopoly now, all the time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Aug 17, 2015

Copy link to clipboard

Copied

While I'm not recommending permanently disabling your wi-fi, it would be helpful if everyone could try temporarily disabling it to see if that helps with performance.  That would help us narrow down what's causing the problem.

Please let me know if it helps in your case.


Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 18, 2015

Copy link to clipboard

Copied

I feel the same way. Photoshop 2015.1 just feels sluggish. It starts with the startup.  PS 2014 is ready to use immediately when I see the user interface, while PS 2015 is unresponsive for 5-10 seconds. The whole PC slows down when the program is loading. Other operations feel slower too. Simple stuff like zooming in or out on an image in the backgroun when a filter window has the focus is faster in 2014 compared to 2015. Same goes for loading images.

I couldn't stand 2015.1 and went back to 2014.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Aug 18, 2015

Copy link to clipboard

Copied

Disregard the suggestion to disable wifi.

I have two more tests that I'd like everyone to try to see if it helps with PS CC 2015.1 performance.

1.  Disable Device Preview - choose Window > Device Preview and then use the fly-out menu to close the window (quit and re-launch after this step)

2.  Disable Generator - go to Preferences > Plug-ins and uncheck "Enable Generator" (quit and re-launch after this step too)

Do either of these changes help with overall performance?

Thanks,

Adam

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Aug 18, 2015

Copy link to clipboard

Copied

Hi,

Followed instructions. I'd say that #1 didn't do anything.

However, adding #2 might have helped a bit: I noticed less lag when I switched, via keyboard, from tool to tool (Marquee is a big offender. But then again, Text Tool and others did as well. Might not matter which tool I am choosing?). I'd say that, yes, overall there was an improvement in lagtime after step #2.

Interesting, that, in general, there were times when I was just looking at cc2015 and the beachball would appear. What is it thinking about, processing, who's it talking to? Even while I am doing literally nothing? Hm!

(it's often very spotty. For instance, I poked around at my deliberately chosen 2300px wide image with the Eraser and things bogged down and yet a few seconds later I was erasing all I wanted with no issues. Ah, but then switch TASKS like just deselecting via keyboard shortcut and the beachball appears. Only for about 1-2secs, but it happened. However, if I am using the Marquee tool and deselect, I don't think I have seen the beachball)

Francis

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 18, 2015

Copy link to clipboard

Copied

Have you tried reducing the History States in Preferences > Performance from 50 to 25 (Restart PS)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Aug 18, 2015

Copy link to clipboard

Copied

gener7,

I just tried that on your recommendation. Doesn't seem to have an appreciable effect.

If anything speeds up performance, it might be working with a smaller version of the same image. Ehhhh...but even then I get lag at the most odd of times; just now I zoomed into my 20%-of-original-size image and got a beachball for a few moments. It's hard to predict!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 18, 2015

Copy link to clipboard

Copied

Ok. I'm running OSX 10.10.5 on a mid 2009 Macbook, so I don't know what problems happens with others. If I think of anything else, I'll certainly leave it here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 18, 2015

Copy link to clipboard

Copied

I tried these two steps as well with no real noticeable improvement. Similar to Bonkersforever, I notice the delays and lag time for some period and then no issues at all for a couple minutes and then it's back to the spinning beachball, while I'm doing nothing.

Not sure if everyone else has this as well, but I'm noticing the exact same issue in both Illustrator and InDesign.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 19, 2015

Copy link to clipboard

Copied

I don't know if this will help everyone, but it made all the difference for me. Since I was having the same delay and hesitation issues in all my Adobe CC apps (Photoshop, Illustrator, InDesign), I tried force quitting out of the Creative Cloud desktop app via the Activity Monitor. Immediately all my apps came back to life. I left it off for awhile and then restarted it and all my apps are running as expected, currently.

It's not really a viable fix since Adobe requires you to be signed in, at some point, to use your apps, but it's helped in the meantime.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 27, 2015

Copy link to clipboard

Copied

I've tried:

  • Disabling font preview
  • Disabling library panel
  • Changing history states to 15
  • Disabling Device Preview
  • Disabling Generator
  • Killing the Creative Cloud app and the CCLibrary.exe process

Still, only reverting to 2014 helps. PS 2014 flies, as do all other programs – including 3DS Max.

The system is plenty fast enough with 32GB RAM, SSD, and dual Quadro cards.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 27, 2015

Copy link to clipboard

Copied

It may make my problem unique from other users experiencing this slowdown in PS2015...but I'm wondering if it's an issue between PS 2015 and the NVIDIA Quadro cards.

My drivers are up to date, and again PS 2015 is the only area I've noticed the issue so far.

But really I'm just grasping at straws here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 27, 2015

Copy link to clipboard

Copied

Yeah PS 2014 works like a dream - i've given up on trying to figure it out, I need to get work done

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 27, 2015

Copy link to clipboard

Copied

Ok I don't know if this qualifies as a solution, but I can get PS 2015 running almost as fast as 2014! (As a reminder, none of the steps below need to be done to get PS 2014 running fast, it just does.)

My conflict seems to revolve entirely around Photoshop CC 2015 and Google Chrome.

On startup, a chrome process loads in the background. It has low memory usage and allows for easy Hangouts connections, so I allow it.

However, if even this tiny Chrome process is running, PS 2015 craaaawls. My benchmarking test was launching the Effects Panel(fx), which would take 20-30sec to load in PS2015! Ex: http://screencast.com/t/jlrOuqrm‌‌‌ -- PS 2014's Effects Panel launches instantaneously.

But if I kill Chrome completely, not just close it, PS 2015 can open the Effects Panel in 1 second. A strange aberration here is if I kill Chrome before launching PS 2015, PS will run relatively fine even if I relaunch Chrome! The Effects Panel launches in 2~sec, with Chrome happily running alongside.

To reinforce the connection between Photoshop 2015 and Google Chrome as the culprit, I Loaded up Firefox and IE with tabs, and ran Illustrator, Spotify, Bridge, After Effects, Brackets, InDesign and SpeedGrade simultaneously --- with no effect on PS 2015's Effects Panel loading speed. It was right at 1~sec.

This is frustrating because PS and Chrome are my two most-used applications, but it looks like I'll be running back to Firefox or at least be making sure PS launches before any Chrome process.

Finally, I think this issue extends beyond just PS 2015. I've noticed slowness in Premiere and After Effects 2015 and will be testing the above steps with those programs as well.

Hope this helps someone!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 25, 2015

Copy link to clipboard

Copied

Quitting Chrome before opening photoshop seems to have fixed this.  Previously photoshop would hesitate for 1-3 seconds before every click (including menus).

No idea if this is a Chrome issue of PS issue, but both are important parts of my workflow!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2015

Copy link to clipboard

Copied

Please let Google know about your issues with Chrome so they can get it fixed ASAP.

(note: Chrome has had issues like this before)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 23, 2016

Copy link to clipboard

Copied

Everything is running fine and dandy, once I can get the program to load (running 10.10.5 on a 2013 iMac standard graphic card etc) which could take literally  5 minutes. (yes I timed it) and if any thing else is running (cloud pull, back blaze, chrome updates, it would go into the classic mac spin. So yes, I started it without wifi and for me that did make all the difference in the world. Loaded in a speedy 1 min. So I guess it would depend on the problem. If it is a cloud based program, would that not perhaps effect it?

As far as the comment from Tidal Wave Creative about users being beta testers- I personally find they ARE the best testers, as they are the ones who use the programs day in day out in the real world. I am a beta tester for the NYT Android app and I know 1% over nothing about the tech side of things. Just what works for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...