Highlighted

Photoshop CC 21.1.0: Cursor jumping away after mouse release for some tools

Community Beginner ,
Feb 28, 2020

Copy link to clipboard

Copied

Now this is driving me insane! Running 21.1.0 on an HP Elitebook running x64 Win7.

With some tools including Clone Stamp, Spot Healing/Healing Brush, Blur, Eraser, and Patch, the stroke jumps up and left about 4 inches after I release the cursor. However, this "jump" doesn't occur with the Brush tool.

This wasn't happening yesterday. I have tried messing with the GPU settings, restarting, un/reinstalling, begging, exorcism, everything. GIF of issue below.

2020-02-28_11-59-20.gif

TOPICS
Bug, Problem or error, Windows

Views

936

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Photoshop CC 21.1.0: Cursor jumping away after mouse release for some tools

Community Beginner ,
Feb 28, 2020

Copy link to clipboard

Copied

Now this is driving me insane! Running 21.1.0 on an HP Elitebook running x64 Win7.

With some tools including Clone Stamp, Spot Healing/Healing Brush, Blur, Eraser, and Patch, the stroke jumps up and left about 4 inches after I release the cursor. However, this "jump" doesn't occur with the Brush tool.

This wasn't happening yesterday. I have tried messing with the GPU settings, restarting, un/reinstalling, begging, exorcism, everything. GIF of issue below.

2020-02-28_11-59-20.gif

TOPICS
Bug, Problem or error, Windows

Views

937

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 28, 2020 2
Adobe Community Professional ,
Feb 28, 2020

Copy link to clipboard

Copied

Hi

It's a known issue with 21.1 and has been reported to Adobe

https://feedback.photoshop.com/photoshop_family/topics/ps-21-1-every-drawing-action-snaps-to-upper-l...

You can revert back to version 21.0.3 from the CC app until Adobe fixes the issues with this new update

2020-02-21 10_28_16-Creative Cloud Desktop.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 28, 2020 1
New Here ,
Apr 01, 2020

Copy link to clipboard

Copied

I'm experiencing the same issue. I tried updating the GPU and Display Tablet drivers but it didn't fix it.

Another thing to mention is that in my case, it does happen with the brush tool as well.

Just as for OP, only click + drag will trigger this issue. Just clicking seems to work fine.

Also, this happens only with the mouse, the tablet pencil works just fine, which makes PS usable 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 01, 2020 0
Community Beginner ,
Jun 10, 2020

Copy link to clipboard

Copied

This bug is still present in the latest 21.1.3. Any updates or progress on this issue or work around?
It happens even with a color picker in any color range or selection mode - not allowing to select an area since the cursor jumps to a complete random position. 
The worst occurence is when using the hand tool to pan with the mouse, it jumps sometimes across the screen panning at a complete random spot making Photoshop totally useless when using the mouse.
Any operation with the Wacom tablet works fine - currently i just use the pen in photoshop, since the mouse is unusable for almost 90% of the time.

Would be awesome to see this fixed as soon as possible,

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 1
New Here ,
Oct 06, 2020

Copy link to clipboard

Copied

this is an extremely frustrating issue that i've been having for months.  My work flow is slowed down and i am beyond back logged now as a result.  It appears to happen in both PS and LR.  If i increase the size of my brush it makes it worse.  Please help Adobe!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2020 0
Community Beginner ,
Oct 06, 2020

Copy link to clipboard

Copied

I had this issue once....it was killing me...I tried everything...it turned out I had set something on my tablet and that was causing the issues. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2020 0