Photoshop CC gradient banding

Community Beginner ,
Feb 25, 2014

Copy link to clipboard

Copied

I've been a using Photoshop for 20 years (as a design professional) and only since I switched to CC a few months ago, I get awful obvious banding when creating gradients. Even in rgb files, which sometimes used to occur in cmyk. Nothing seems to get rid of it, and I'm NOT looking for a noise or blur solution, please, so don't suggest that.

I did the same actions in Adobe 4 which I still have on another computer and it doesn't occur. I hate this. Any suggestions? I have a new latest iMAC so it doesn't seem like that would be the issue.

It is not a problem - it is a result of having very smooth gradations display or printed on systems with quantization levels (how many bits are displayed/printed) that cause visible banding.

And the solution is always the same: add enough noise to make the banding invisible.

Views

62.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mentor ,
Feb 25, 2014

Copy link to clipboard

Copied

Is the banding showing up in print or on-screen?  Or both?  In the old days, banding showed up in low res monitors or monitors showing only 256 colors.  I wonder if it could be related to the monitor or the video card?  I still do not understand how software development has not evolved to the level of zero defects.  That goes for hardware, too.  They wrote these applications and operating systems years ago and I would think that, by now, they'd have perfected everything to work in concert.  Guess I got a wiff of laughng gas.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 25, 2014

Copy link to clipboard

Copied

I think it's a screen issue since after I posted this I thought I'd try it on my older iMac. Looks fine. Spent hours on phone with AppleCare and they have no idea what I'm talking about. Never heard of banding. Right.

Sent from my iPhone

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mentor ,
Feb 26, 2014

Copy link to clipboard

Copied

A quick test if the video card is causing these issues is to turn off hardware acceleration in the preferences, and restart Photoshop.

Does it still occur after turning that off?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 26, 2014

Copy link to clipboard

Copied

I can't see where that's an option in preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mentor ,
Feb 26, 2014

Copy link to clipboard

Copied

Performance tab-->use graphics processor. Uncheck and reboot photoshop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 26, 2014

Copy link to clipboard

Copied

I had tried that before. Tried it again. Nope. It seems like contrast SOOOO high, accentuating the banding. And it's set to the lowest.

I've tried everything, Besides it's the same in illustrator. EVerything looks striped. Not as smooth as it should be at all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2014

Copy link to clipboard

Copied

A bad display profile could exaggerate banding, as could a bad display (particularly laptop LCDs).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mentor ,
Feb 26, 2014

Copy link to clipboard

Copied

And the screen is colour calibrated? It might be a defect in the screen's hardware - I know that the video hardware applies certain debanding tricks. Have you checked with an identical iMac (for example in an Apple store)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 26, 2014

Copy link to clipboard

Copied

Herbert, I thought I'd try that (bring a file into the stiore, see what it looks like on a similar machine. Computer is a late 2013 iMac (latest upgrade in November), All Adobe Creative Cloud software, Mavericks OS (latest upgrade) So NOTHING is old.

Maybe the displays are just not what they used to be. It's bright and color is OK, but it's so contrasty for my taste. Edges that should be soft are harsh. And then the banding is not good. It makes it tricky to see what I'm really getting.

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 26, 2014

Copy link to clipboard

Copied

And it's calibrated, but by me, like I usually. do. The default setting is even worse.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mentor ,
Feb 26, 2014

Copy link to clipboard

Copied

I agree - and unfortunately the quality of Apple screens is not what is used to be years ago. I teach in Apple labs and I have seen a degradation in screen quality over the years, with contrast given precedence over colour quality.

Btw, Mavericks is the buggiest MacOs in a long time (ever?), and I have read accounts about how it affects video hardware negatively as well. Did you install CC on the older mac for comparison?

Otherwise you may have to get a second high-quality screen meant for graphics design and work on that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 26, 2014

Copy link to clipboard

Copied

Mavericks IS buggy. I can't install CC on my older one, since I still want to keep Adobe CS4 stuff there.

And getting a secind screen, yeah I guess, but then there was no point in getting an iMac. I couldve gotten a Mac Pro model and a separate display, but I haven't and don't want to keep buying equipment right now.

This SHOULD be a high quality screen!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mentor ,
Feb 26, 2014

Copy link to clipboard

Copied

I wonder if it's Photoshop > Preferences > General > Image Interpolation = Bicubic ( best for smooth gradients )?  In Illustrator > Preferences > General > select Anti-Aliased Artwork.  I am not running Mavericks or any creative crud crapware, so the only thing, other than what I already posted, I can think of is application specific Preference settings.  Photoshop Image Interpolation set for Bicubic seems like a likely solution, is that selected or not?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 26, 2014

Copy link to clipboard

Copied

Yes, I checked that. nope. I'm thinking it's not sioftware related now, like I thought at first.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mentor ,
Feb 26, 2014

Copy link to clipboard

Copied

To figure out whether this is due to faulty hardware or the OS, you could install Windows, and install CC for Windows. If the gradients display fine, you have your answer.

Might be a bit much, though, to go through all that merely to check whether this is an OS or hardware issue... 😉

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mentor ,
Feb 26, 2014

Copy link to clipboard

Copied

Is that a Retna Display?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 04, 2017

Copy link to clipboard

Copied

You let Apple Care take up your time? Sorry man, but they're looking stuff up on the internet just like the rest of us, but they're getting paid to do it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 03, 2014

Copy link to clipboard

Copied

I am having the same issue and was thinking it was my monitor until tonight.  I realize now that it's PS CC that's causign the problem.

I had the CS6 subsctiption before I upgraded to the photographer's bundle with LR.  When I first noticed the banding working in PS CC, it didn't occur to me that it was the change in software...

I also have an iMac, but mine is much older than yours as I got it early in 2010.  When I first noticed this banding, I thought it was my computer that was causing the problem,  but I now I really don't think that's the problem.

Tonight, I re-processed some photos of Northern lIghts that I took and first processed back in July.  At that time I was using the online version of PS6. 

While doing these new edits tonight, I noticed the banding and was unhappy with it.  I attributed it to my computer and did my best to ignore it.

Then I brought the new PSD files back into my LR catalogue and looked the old PSD files(which I thankfully kept).  The original files I processed in July with CS6 are beautiful and clean with smooth and creamy looking transitions.  The ones I just processed with PS CC are unacceptable and look like Netflix on a bad day, and I wouldn't even show them publicly.

It's late now, but I need to put in a support ticket as this is unacceptable.  I want CS6 back...

Lisa

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2014

Copy link to clipboard

Copied

No, this is not a problem with Photoshop CC.

It could be a problem with your display profile (try changing it in the system settings) or your video card driver (try updating it from the GPU maker's website).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 06, 2014

Copy link to clipboard

Copied

Then why are the files saving with the problem showing on other peoples' computers, and why do I have a copy with the exact same NEF file, done on the exact same computer, but with CS6 that looks clean, while the one done with PS CC looks so bad the files aren't usable?

The jpegs save with the problem visible.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 06, 2014

Copy link to clipboard

Copied

I don't know what mistake you might be making, but you have to be making a mistake somewhere to have gradients appear differently in CS6 and CC.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guide ,
Mar 06, 2014

Copy link to clipboard

Copied

Just for drill, could you please post a screenshot, or a jpeg/png of the issue you are having? (Even a test file, if it shows the problem.)

I'm using CC, haven't had this issue, and am wondering if I can recreate your problem here.

Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Engaged ,
Mar 10, 2016

Copy link to clipboard

Copied

"No, this is not a problem with Photoshop CC."

then why does this exist? Honest question, may be outdated.

Photoshop Actions to fix the banding of Photoshop's gradients.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 10, 2016

Copy link to clipboard

Copied

Because the author of that action was very confused about what actually causes the banding.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Engaged ,
Mar 10, 2016

Copy link to clipboard

Copied

I won't disagree without knowing the complexities of the gradient tool etc, but the end result of using this action is an unbanded gradient where as the end result of a gradient in photoshop is often banding.

I notice that other apps seem to do this (clean gradients using dither or noise, anecdote), like apples professional tools (iwork suite, motion etc). I may be completely missing the point here, but I prefer tools that achieve a quality outcome regardless of semantics as opposed to tools that follow engineering principles or rules that are irrelivant to the end user at the expense of quality. But i understand that both approaches have their merits.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 10, 2016

Copy link to clipboard

Copied

The action is more complicated than it needs to be, and converts to 16 bit/channel (which can make banding worse!).

Photoshop's gradients already have dithering to reduce banding. But issues with adjustments, displays, compositing, etc. can introduce more quantization and show banding again if you are not careful.

There is no simple fix beyond knowing what is going on, and adding noise to reduce the appearance of banding.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Engaged ,
Mar 10, 2016

Copy link to clipboard

Copied

Thanks Chris. The 16 bit part of the action is separate option, but I can see that you're right and it does make the banding worse. To your point most of the issues i have with banding are involving adjustments, ill take a look at changing my workflow.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Mar 06, 2014

Copy link to clipboard

Copied

I'm surprised to see no mention of dithering settings in this thread.

I too would like to try to see or reproduce the problem.

-Noel

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 14, 2014

Copy link to clipboard

Copied

I switched camera from Canon to Hasselblad. Now I see banding in Photoshop. I use top of the line Eizo monitor.

The strange thing is that all looks fine in Phocus, Lightroom and Camera Raw. See attached screenshot.

What's going on?

PS CC to the left and Camera Raw to the right.

Link the the image: http://www.botvidsson.se/waste/banding.jpg

http://www.botvidsson.se/waste/banding2.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mentor ,
Mar 14, 2014

Copy link to clipboard

Copied

I opened your jpg in Photoline, and the banding was quit obvious in both versions, until I switched to 16pbc. Then the right version looks much better. In Photoshop CS6 I did not need to switch to 16bpc to see the right version looks better (PS probably uses some internal 16pbc-->8bpc conversion for improved gradients blending).

However, Jpg is the worst format to use for this particular example: a 16bpc png or tiff would give us a better idea of what is going on.

Having said that, the dithering used to reduce banding in the left version seems to be of a lesser quality compared to the version on the right - which would explain the higher quality of the right version.

To create a much better 8bpc version I applied some grain/noise to a 50% grey layer in overlay mode and a layer mask to avoid adding noise in the brighter areas of the image:

www.estructor.biz/testje/banding3.jpg

Can you upload the same image in a 16pbc format?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Mar 14, 2014

Copy link to clipboard

Copied

OK, I see that you're using the ProPhoto RGB profile.  I've seen some pretty severe banding with that as well, though on a PC system.  I don't know if your Mac might suffer from the same issues...

Try a few experiments to see if what you're seeing is what I've seen.

1.  Convert the profile of the image to sRGB IEC61966-2.1 and see if it clears up.

2.  On the original image with which you're seeing banding, choose Window - Arrange - Float all in Windows and see if when you grab the window and start to move it the problem clears up (Photoshop switches from GPU-based color-management to CPU-based when you do this).

3.  Try configuring your Photoshop - Preferences - Performance, [Advanced Settings...] to "Basic" drawing mode, then Quit and restart Photoshop.  This causes Photoshop to use CPU-based color-management.

-Noel

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 27, 2017

Copy link to clipboard

Copied

Was having the same problem - did this (switched Drawing Mode preferences from Advanced to Basic) and it seems to have fixed the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 04, 2014

Copy link to clipboard

Copied

Greetings from Boise. I'm in a big rush so didn't go through all the answers, but have some suggestions (late to the party, I know).

In RGB banding is more likely if you have a dominant hue, such as Blue (which accounts for far less than 10% of any Pixel's Luminance value). Additionally, it is more likely if you are working in 8 bits per Channel: this is due to "Quantization," or the Luminance "steps" between various Channel values. In 8 bits, there is a noticeable difference between, say, 125 and 126. Again, this is most noticeable with a dominant Hue. Human vision is very sensitive to Luminance Deltas (differences).

Work in 16 bits, aRGB (not PPRGB, nor sRGB). I know there are arguments for sRGB, but: http://www.forensicallyfit.net/2012/04/16/argb-srgb-gamut-accuracy-conversion-delta-e/

When you build the Gradient, in the Gradient Dialogue Box ensure that you select adjust the "Smoothness" control up. This will produce a dithering in the Gradient to combat Posterization. Additionally, when you have the Gradient Tool Selected, check your Options ToolBar to ensure that the Dither checkbox is selected.

There are some very clever things you can do like overlaying and averaging Gradient Layers, but I mention that because it is only necessary in extreme cases.

Here's a good exercise: generate a monochromatic (0-255) Linear Gradient without Smoothing and without Dither. Note the shape of the Histogram: it is "platykurtic," meaning that it is very flat and regular.

a.PNG

Now-without changing the Gradient Stops or Colors, apply Smoothing and/or Dither, or both:

b.PNG

Now the Histogram is neither evenly distributed nor smooth. This tells you-primarily-that what amounts to Noise (synthetic value Pixels) are being generated by PS in the background to blend the various Quantization Levels. You will probably not find them objectionable in even large prints. This is a superb way to mitigate "banding."

Finally, you should know about a "gotcha." You'll notice (using your Info Window) that the Pixel Values of a 16 bit Document range from 0-32768, which represents 15 bits, not 16 (which would range from 0-65535). So, you are actually working in 15 bits, but the difference is unimportant to the human eye...unless, like me, you hallucinate a lot. Ahem. Anyway, you are in 15 bits (this is done to accomodate Blending Mode math).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...