Photoshop CC gradient banding

Feb 25, 2014

Copy link to clipboard

Copied

I've been a using Photoshop for 20 years (as a design professional) and only since I switched to CC a few months ago, I get awful obvious banding when creating gradients. Even in rgb files, which sometimes used to occur in cmyk. Nothing seems to get rid of it, and I'm NOT looking for a noise or blur solution, please, so don't suggest that.

I did the same actions in Adobe 4 which I still have on another computer and it doesn't occur. I hate this. Any suggestions? I have a new latest iMAC so it doesn't seem like that would be the issue.

It is not a problem - it is a result of having very smooth gradations display or printed on systems with quantization levels (how many bits are displayed/printed) that cause visible banding.

And the solution is always the same: add enough noise to make the banding invisible.

Views

60.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 24, 2016

Copy link to clipboard

Copied

Im making depth maps in Photoshop CC 2015 - used to be very straight forward: Create a high res ( ie 4000 by 4000 ) sRGB document, paint various soft shades of grey using 0% hardness in 8 Bit mode, export as a png.

Now Im getting this serious banding on every blend or soft brushstroke. Its DEFINITELY not a display issue, as when these pngs are opened as maps in my 3d software, the banding becomes actual 3d steps in height/depth on my mesh. This means the image I see ( with banding ) in Pshop is exactly what is in the file and thus what is being exported.

Working in 16 bit mode helps a certain amount, but doesnt entirely remove the issue. Seriously considering using GIMP or something...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 24, 2016

Copy link to clipboard

Copied

The blending and painting code hasn't changed in Photoshop. Odds are that there is something going on in your workflow that causes the increased quantization/banding (like a bad PNG reader that believed the PNG 1.0 instructions to always convert gamma values).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2016

Copy link to clipboard

Copied

Don't waste your time.adobe is busy in releasing adobe cc 2016 version. they won't take care this problem.people like us spending years searching solution

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2016

Copy link to clipboard

Copied

Er, did you reply to the wrong topic by mistake?

This topic is not about a bug, and there is nothing discussed here for Adobe to solve.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2016

Copy link to clipboard

Copied

I want to share my experience with this. I just got a new computer (Alienware Area 51, Titan X, the works) for work and using Adobe Photoshop CC2015. Just a regular gradient/blur brush resulted in heavy banding. My eventual fix was manually changing the monitor's color profile to match the default Photoshop color profile. So, in detail...

1) Under the Color Management window in Windows (for me Windows 10), I "Add..." the color profile I want PER monitor. In this case, I am adding sRGB IEC61966-2.1 to the list. I select it, and "Set as Default Profile". I do this for each monitor I have.

2) I make sure this is the same profile I use under Edit > Color Management in whatever version of Photoshop I am using.

For me, this fixed my banding issue. Hopefully this will help someone else out there as well.

Likes

5 Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2016

Copy link to clipboard

Copied

OK, that means that your default display profile had problems that exaggerated quantization/banding.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2017

Copy link to clipboard

Copied

I find it amazing that this haven't been fixed yet. It has become quite clear that it doesn't have to do with peoples settings or/and monitors etc since everyone no matter what workingstation or screens they have, all have the same issue.

As I've seen some others say before me, this problem hasn't occured in previous versions of Photoshop but rather in the later. I've worked in Photoshop for many many years and there IS a difference, and a clear one at that. It's very annoying and upsetting to work with gradients all the time and see this in every single image...

We need to get a CLEAR explanation as to why this is happening. Please don't give us some bull**** about how "it's a feature" or "there is nothing wrong with the program". We all know that there is something that's not quite right here. If you can't fix this, at least tell us where this issue originates from.

PS! I know that there are workarounds using noise or blurs etc. That's not a real fix. Make it work and don't pretend like it already does.

Thanks...

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 18, 2017

Copy link to clipboard

Copied

In an 8-bit file, you will see the individual steps from 0-255. That is irrespective of the application used.

In a 16-bit file, any banding you see is in the display system. You have obviously made up your mind that it's Photoshop, but you'd have a much better chance of reducing it if you acknowledged where the banding actually happens.

Most monitors and video cards still work at 8 bit depth, so the 256 steps again apply. Beyond that, irregular banding could be a bad display profile, calibration tables in the video card (most common cause), or the panel itself.

In addition, jpeg compression can introduce color banding.

BTW, the amount of noise required to break up the banding is no more than you have in a very fine-grained photograph. You really have to pixel-peep at 1600% zoom to see it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 28, 2016

Copy link to clipboard

Copied

Billy this solved my problem immediately and 100% - great work and thanks for sharing. No need to change any of PS/graphics card settings.

Many thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...