Photoshop drawing straight lines randomly while using Wacom tablet.

Contributor ,
Oct 11, 2018

Copy link to clipboard

Copied

Hello.

The issue im talking about (popular issue i have googled for days/weeks now and all i found was unsolved threads - some for over 8 years): When i use brush to stroke some curved lines, randomly photoshop instead of rendering my brush strokes renders straight line from the start point to the end point of the stroke i made with pen, and renders them (straight lines) only after i finish the stroke and lift the pen (i see nothing while doing any random moves with brush untill i end it when the issue is on).

I have tryied all the tips and tricks i found via googling (disabling windows ink, changing registry key, creating ps user settings txt file, switching usb ports, updating everything - including gpu drivers, windows, photoshop)

Im currently on:

4x3,4Ghz CPU

Windows 10 64bit

8GB of ram

GTX970 gpu

Wacom Intuos 4 PTK-840 connected via USB

I have cranked the speed of periods of time where i coudlnt reproduce the issue, but i kept the whole test as single video without cuts.

(ignore 2 straight lines around 1:52 - those were drawn by me - not the issue - you can see difference tho - they are shown as being drawn, insetad of popping up instantly). Also, move to 0:45 to fastforward to first occurance of the issue.

What i have learned from the testing session trying narrow down what causes the issue:

  1. I coudlnt reproduce it inside Wacom's calibration tool (where you can test pressure)
  2. Its unrelated directly to PS's OpenGL settings (it happens with it on any of the settings - basic, normal, advance as well as with it unchecked whatsoever)
  3. It might happen bit more often and its quicker to reproduce while working with heavy file with lot of big smartobjects and layers with overlay effects, but its definitely not exclusive to those files - happened on almost empty 2048x2048 canvases too.
  4. It happens most often after panning the zoomed view. And the more area and the longer i pan the view the bigger next stroke's chances of being flawed with that issue. As you can see on the video, the small pans of the view/canvas or not panning at all makes it hard to reproduce the issue. But as soon as i start doing wide, long pans the issue shows often (at the end of the video i got better at it - or the amount of "paint" on the canvas did the trick).
  5. I got close to 90% reproducing rate for first stroke while opening one of my heavy textures files, rotating canvas -90 degrees zooming greatly, panning a lot and then doing first brush stroke. So while its not exlusive to OpenGL, the canvas rotation that it allows might influence it aswell.
  6. The issue often persists longer after those longer panning of the view, untill i make a pause in between the concurrent brush strokes.

Ok i think i was able to fix it.

I have noticed that it never happens in other circumstances, but only after i use the hand tool on tablet's hotkeys to pan the view. So i went and tested if it happens if i would use spacebar insetad and it didnt.

I have changed tablet's hotkey from hand tool to simply spacebar, and seems it dont happen anymore. Didnt do extensive tests yet, but done quite a bit and results are good so far. If that would change i will update it here.

At this point i cant say if its Wacom or Photoshop issue, but surely it could be fixed on ANY end, if its caused by hand tool hotkey functionality exclusively.

Views

13.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Apr 26, 2020

Copy link to clipboard

Copied

I have this problem with my tablet and my mouse So it's not the tablet. Is there a preference setting to fix this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 29, 2020

Copy link to clipboard

Copied

I've noticed that in the video that you posted, your rulers are turned on.  This might sound crazy, but, turn them off.  It worked for me on a Mac.  Someone suggested it to me and I'm incident free.  Good luck.  It was probably the twentyfifth "fix" that I tried.  I sincerely hope that this works for you.  As I know how frustrating and how it compromises your productivity.  This suggestion came from a rep at Wacom.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 24, 2020

Copy link to clipboard

Copied

Turning off rulers seems to work for me to too in a quick test. MacBook Pro early 2013 on Catalina with a Huion 950p tablet and the latest drivers installed. Bloody hell. Adobe, please fix this!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 06, 2020

Copy link to clipboard

Copied

This has worked for me too, thanks SO much, this has been driving me crazy for months! Adobe fix this issue! iMac 2017, Mojave and Wacom 13HD

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 11, 2020

Copy link to clipboard

Copied

Sadly none of these "fixes" helped me and or resolved the problem.

If anyone has any other ideas pls tell right them as a reply.

using a Wacom Intuos Pro M and photoshop 2020. (the problem remains)

btw I can always 100% reproduce this problem by tapping shortly multiple times in a small area of the canvas.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...