Photoshop freezing for 20 seconds after opening an image

Community Beginner ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Hey folks,

As the title suggests, Photoshop is haning for about 20 seconds each time I open the first image after starting the program - no matter if big or small. After that waiting time, everything works as expected. When I open more images, the problem is gone. But after closing/restarting Photoshop, the problem is back. During these 20 seconds of freezing, the Windows task manager says the process photoshop.exe is dead. But then it unfreezes after that waiting time.

 

I also had this issue with previous versions of Photoshop (all CC 2020 and 2021), but then after an update it disappeared for 2 months or so - until las month, when it came back again. Would be awesome if you could look into this issue since I'm loosing a lot of time everyday while waiting for Photoshop to open my files... Thanks in advance!

 

Additional info

Program version: Photoshop CC v 22.3 (problem was also on 22.2 and older versions, but not on CC 2019 and older)

OS: Windows 10 Pro 64 bit

Driver: Nividia Studio Driver 461.72

GPU's: 4x Nvidia RTX 3090

RAM: 128 GB

HD: Samsung SSD 980 Pro (M.2)

TOPICS
Bug, Crash or freeze, Problem or error, Windows

Views

75

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Mar 10, 2021 Mar 10, 2021
Hi I suggest you adobe clean remove tool to remove all older files then use Photoshop 2020 hope it will work great for you new version have some bugs...regards

Likes

translate

Translate

Translate
Adobe Community Professional ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Hi I suggest you adobe clean remove tool to remove all older files then use Photoshop 2020 hope it will work great for you new version have some bugs...regards

Ali Sajjad

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Hi! Thanks for the tipp, this actually worked! After a fresh install, the lags are gone. Thank you!! 🙂

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines