Highlighted

Photoshop is really slow on Windows 10

Nov 12, 2019

Copy link to clipboard

Copied

Hi friends.

I have an excelent computer (http://prntscr.com/pvxv3a) and a GeForce 1060Ti

But the Photoshop is really really slow with this program

Everytime i open a font, it takes about 10 seconds just to process and the program dont run smooth.

Sorry if it's repetead, it's my 1st thread.

Any one has face it ?

Thanks

Topics

Crash or freeze, Problem or error

Views

116

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Photoshop is really slow on Windows 10

Nov 12, 2019

Copy link to clipboard

Copied

Hi friends.

I have an excelent computer (http://prntscr.com/pvxv3a) and a GeForce 1060Ti

But the Photoshop is really really slow with this program

Everytime i open a font, it takes about 10 seconds just to process and the program dont run smooth.

Sorry if it's repetead, it's my 1st thread.

Any one has face it ?

Thanks

Topics

Crash or freeze, Problem or error

Views

117

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Nov 12, 2019

Copy link to clipboard

Copied

It might be worth resetting your Photoshop preferences, which you can do under the General tab in Photoshop preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2019

Copy link to clipboard

Copied

I've already tried...
It's still slow...

(PS: I use, Illustrator, After effects they all work smooth... just photoshop is slow 😕 )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 12, 2019

Copy link to clipboard

Copied

Hi there,

We're really sorry for the slow performance issue. Are you facing this issue with the latest version of Photoshop 21.0?

 

If yes, please turn on the legacy compositing in Photoshop preferences > performance tab > restart Photoshop and let us know the results.

 

Thanks,

Mohit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 12, 2019

Copy link to clipboard

Copied

Hi.

I just did it, but it still not smooth as it should

https://www.loom.com/share/7590eeaf04e7414a9dfd43953cf4b14b

I run photoshop on worst computer, and they work more smooth than mine that's way better.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
teleleo LATEST
Nov 13, 2019

Copy link to clipboard

Copied

Can you help me please?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...