Photoshop more laggy on 4K monitor compared to 1920x1080 monitor on Windows 10

New Here ,
Jun 26, 2020

Copy link to clipboard

Copied

Hi,

I've realised that photoshop performs a lot slower on my 4K display than my HD display. I work on a PC with dual-monitor (Samsung S27E390 - HD and ACER KG281K - 4K).

 

Here are the following specs:

  • AMD Ryzen 9 3950x 16-core processor

  • Corsair Vengeance LPX 3000mhz 64gb DDR4 RAM

  • MSI ARMOR GTX 1080ti OC 11GB

  • Sabrent 1TB Rocket NVMe PCIe M.2 2280

 

I have Use Graphics Processor checked and Drawing mode as Advanced.

 

I have recorded videos to show the problem when I just move around a grouped asset:

On Samsung display it is a lot smoother and snappier - video

On Acer display it is slow and choppy - video

I have also tried setting the resolution of the Acer monitor to 1080p and it moves smoothly.

So does the current PS have a problem with 4K display?

 

Was wondering if anyone else is experiencing similar problem?

Would like to hear any advice.

Thanks.

 

EDIT: I am using the latest version of Photoshop (21.2.0) and have Geforce Game Ready driver version 451.48.

TOPICS
Bug, Performance, Problem or error, Windows

Views

628

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 26, 2020

Copy link to clipboard

Copied

Try the studio driver. Sounds like a driver bug.

 

Also try to reset PS preferences.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jul 01, 2020

Copy link to clipboard

Copied

I had this issue moving to an LG CX with a 2080 Ti. Nothing worked until I disabled G-Sync for both fullscreen and windowed program, and that fixed it right up. Photoshop and G-Sync really do not mix, and there were sporadic lag issues I would encounter even before moving to a 4k display that also got fixed up by disabling G-Sync.

 

Instead of disabling windowed G-Sync globally, it's probably better to go to Nvidia Control Panel > Manage 3D Settings > Program Settings > Photoshop.exe and set Monitor Technology to Fixed Refresh in order to prevent Photoshop itself from trying to use G-Sync. This way Photoshop will return to its smooth glory no matter your global G-Sync settings.

 

Hope this helps.

 

gysncfix.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 03, 2020

Copy link to clipboard

Copied

I tried to change the Monitor Technology setting in the nVidia Control Panel but it didn't help me at all, however after playing around with other settings I've found one which did the trick. I've changed Vertical sync to off.

 

jurajz14892039_0-1601749953321.png

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 26, 2020

Copy link to clipboard

Copied

Thank you very much! This fixed my lag issue in Photoshop after I bought new 4K monitor that has G-Sync.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more