Photoshop not rendering Image correctly

Explorer ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

Hi guys,

 

today I started working on a big project (in pixel dimensions).

My file is 100x100cm with 300 dpi (around 11.000x11.000px).

It's Adobe RGB with 8 Bit. That's important because the bug I describe just fits perfectly for 16 Bit images and I know that it's a known "issue" there.

 

But first to describe my problem: I got a lot of layer packed into a smartobejct and now want to apply some filters to it. But the bottom right corner of my image doesn't get rendered in my "original" file (see screenshot).

Not at 100% zoom, never. 

When I open the smart object it kinda works. But only at 100% (sometimes) and then it's so large I can't work properly on the image because I need to see everything for a few steps.

 

 

My setup is:

 

mac OS Catalina 10.15.3

MacBookPro 15 inch 2017

3,1 GHz Quad-Core Intel Core i7

16 GB 2133 MHz LPDDR3

Radeon Pro 560 4 GB Intel HD Graphics 630 1536 MB

 

So, as you can see, it's the best specced MacBookPro in 2017. So, I don't think this is a performance problem (also because I have a dedicated GPU).

 

I use the latest version of Photoshop (21.1.1)

I also switched my settings around in the performance tab of Photoshop.

Currently it's set to Cache level 6, OpenCL and GPU acceleration everything checked. My graphic mode (if it's called like this, I don't have the English version of Photoshop) is set to advanced. Before I've set this to simple/ basic because I had some issues in cmyk.

 

 

Do you guys have any recommendations what I can do?

I think work on a smaller image with smartobjects and scale it up won't work, because I'am working with layermasks that would become blurry on rescale.

 

Thank you for your help. If you need anything else from me, just let me know. 

 

 

Bildschirmfoto 2020-04-04 um 15.45.17.png

TOPICS
Bug, Mac, Performance, Problem or error

Views

496

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

I see several potential issues and would try the following , in this order.

 

1. Check the image at 100% zooom. At views less than 100% zoom then previews are used to blend the image and visible artifacts can sometimes be seen which do not appear in the full resolution image.

2. Try checking "Legacy compositing" in Preferences Performance (you will need to restart Photoshop). This puts more load onto the CPU rather than the GPU, but can bypass GPU driver bugs

3. You are using two GPUs which is a known cause of issues in Photoshop. Try forcing Photoshop to use only the Radeon. See sections 7 & 8 here:
https://helpx.adobe.com/uk/photoshop/kb/troubleshoot-gpu-graphics-card.html

 

 

Dave

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

Thank you. I've tried "Legacy compositing" but it didn't work for me unfortunately. 

Your post about how to disable one GPU is for windows. I'm on mac, but I look deeper into if to find out if there is something similar for mac. 

Also I attach an image with 100% zoom.

Same issue. But it's weird that one layer is displaying, and the others are cut down.

Bildschirmfoto 2020-04-04 um 17.36.58.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

Hi

Can you upload the PSD so we can take a look at it.

 

Dave

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

BUT: I just found out, that when I open the smartobject the bug is gone. It's displayed at every % correctly. So I think it's just the smartobject thats bugged. I try to create it again and see if it's gone.

By the way. When I export this strange looking image, everything is as it should be. It's just not displayed correctly within photoshop.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

That is a lot of pixels but Photoshop should be able to handle that well. We can tell nothing from you screen capture for several reasons. This site resizes full screen Capture to small to be readable. And also your layers have been combined into a Smart Object so we can not even see what their reduced size minute  thumbnails may look like, see their type or even imagine how the may composite together. All we have is your statement stating it not being done correctly on your machine.  If you save the document as a PSD and upload it and post a link to it. We could see if it renders the same on our machines. And if it does we could edit the Smart  Object to see  if the layer are composite correctly or not.   I do not seem to have any problem like that on my Window 10 PS 21.1.1 machine.

JJMack

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

I could send you the file. But it's actually a .psb because of it's size (3 GB). The "Legacy compositing" tip dave gave me worked for my smartobject. But not for the "final" file. I take a closer look into it.

 

To tell you how I created the smartobject: I just selected every layer, rightclicked it and transformed it to one smartobject.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

If you do not have "Legacy compositing"  checked in you preferences do as Dave wrote try using stuff that has worked for years. I do check it in mine....

JJMack

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 25, 2021 Mar 25, 2021

Copy link to clipboard

Copied

Funny though that for the last 5-7 years we have all had to turn off anything to do with using the GPU because it just plainly does not work and probably never well. This applies on both Mac and Windows. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 25, 2021 Mar 25, 2021

Copy link to clipboard

Copied

"Funny though that for the last 5-7 years we have all had to turn off anything to do with using the GPU"

 

Not all of us. I have run with the GPU acceleration on for years, using a variety of GPUs and many drivers with only two issues.

The first was few years ago when a AMD GPU driver update caused problems with slowness in the print dialogue. Reverting the AMD driver resolved that.

The second being a couple of weeks with Photoshop v22.3 which introduced a bug when using 30 bit displays Temporarily reverting to v 22.2 whilst the bug is resolved has sorted that.  I always use NVidia Studio drivers for my recent NVidia GPUs.

 

Dave

 

 

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 25, 2021 Mar 25, 2021

Copy link to clipboard

Copied

Same here. The three Nvidia Quadro cards I have had, have all been extremely reliable and well-functioning on Windows 10.

 

And again, the first issues I have ever had, were in PS 22.3, same bug that Dave mentions. So I had to revert to 22.2 which again works perfectly.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines