Photoshop - Smart Guides creates little lags

Community Beginner ,
Mar 13, 2021 Mar 13, 2021

Copy link to clipboard

Copied

Hello, Photoshop community,

 

  • I have noticed that when using Smart Guides my Photoshop is having a split second lag when they appear. This occurs especially when I have a layer selected and I use Ctrl + mouse wheel in order to zoom. The software has this super short lag in between the different zoom scales and it gives a jerking feel to my workflow which is unpleasant.

  • This thing does not appear on Illustrator, so I suspect this is a Photoshop bug?
  • I have noticed as well that if I uncheck my GPU acceleration (GeForce GTX 1650 Ti) the Smart Guides lag does not appear, but of course the whole workflow is painfully slow.
  • My workaround was to uncheck those Smart Guides, but this is not ideal I think.

 

PS: Windows 10 Pro, latest version, GPU all up-to-date and GPU acceleration checked.

Thanks for the help!






TOPICS
Bug, Performance, Problem or error, Windows

Views

312

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Apr 13, 2021 Apr 13, 2021
Hi there,   This issue should be fixed in the Photoshop 22.3.1 update that went live today. This update includes fixes to some of the top customer reported issues among other bug fixes. See Bug fixes and security updates   To update Photoshop to 22.3.1, click "Update" in the Creative Cloud desktop app next to Photoshop. See: More detailed instructions for updating   Let us know how it goes. Thanks, Akash

Likes

translate

Translate

Translate
Adobe Community Professional ,
Mar 13, 2021 Mar 13, 2021

Copy link to clipboard

Copied

Hi,

Check out this link it might help you: https://helpx.adobe.com/photoshop/kb/photoshop-slow-lags.html

Sim

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Hi there,

 

We're sorry for the lag issue. Could you please turn off the GPU from the Photoshop preferences and relaunch Photoshop and let us know if that helps.

 

Thanks,

Mohit

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

Hi there,

To add to what others have suggested, please have a look at this article and see it helps: https://helpx.adobe.com/photoshop/kb/troubleshoot-gpu-graphics-card.html

 

You may also have a look at this conversation and see if the workarounds suggested here helps: https://feedback.photoshop.com/conversations/photoshop/photoshop-223-guides-very-laggy-when-dragging...

Let us know how it goes.
Regards,
Sahil

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 13, 2021 Apr 13, 2021

Copy link to clipboard

Copied

Hi there,

 

This issue should be fixed in the Photoshop 22.3.1 update that went live today. This update includes fixes to some of the top customer reported issues among other bug fixes. See Bug fixes and security updates

 

To update Photoshop to 22.3.1, click "Update" in the Creative Cloud desktop app next to Photoshop. See: More detailed instructions for updating

 

Let us know how it goes.

Thanks,

Akash

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

Hey @Akash Sharma ,

 

Thanks for joining the discussion!

I have just updated Photoshop but unfortunately, the problem still persists. it still the same thing, a 0,5 sec freeze before the Smart Guides appears while zooming in/out.

 

But what I notice is that my photoshop is now having bugs recognizing my GPU... it says it is an unknow GPU...
I don't know if this is a bug caused by the fact that I have a discrete GPU on my laptop, or that fact that I move from my external screen to my laptop quite often 😕

Thanks!

 

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 15, 2021 Apr 15, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear that issue still persists with the 22.3.1 update as well.

 

As you've mentioned that you have an discrete GPU with dual screens connected. Have you checked if the issue persists with only one main display connected to your computer? 

 

Also, please make sure that your GPU drivers are up to date. See: https://helpx.adobe.com/photoshop/kb/troubleshoot-gpu-graphics-card.html#GPUandgraphicsdrivertrouble... 

 

Thanks,

Akash

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines