Photoshop still dead slow

New Here ,
Mar 02, 2021 Mar 02, 2021

Copy link to clipboard

Copied

Hi All, 

New to posting here but been using PS since v3.  I have two licences for two users for full CC and a few other bits as part of a small business subscription.

 

Neither of teh PS users are 'power users' and the current files we are editing are modest JPGs of <3000 x3000.  Device being used in one case is a Surface Pro7 with i7/16Gb.  Not top I realise for proper photo editing but PS has worked fine for many years with similar spec hardware.

 

But recent PS updates have rendered absolutely bloody useless.   I struggle to crop a <1000x1000 graphic as the system is like working through treacle. 

 

I mistakenly clicked update in CC App and that was the end of a working system!

 

Have tried removing everything and reinstalling but still useless.

 

Can anyone advise what the latest 'solution' to this problem is.   I've read various posts from upgrading to 2021 (22.x?), upgrade Windows (20H2 already).

 

Many thanks, Mark.

TOPICS
Performance

Views

74

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 02, 2021 Mar 02, 2021

Copy link to clipboard

Copied

Hi. Please check this link, maybe can be helpful: https://helpx.adobe.com/photoshop/kb/photoshop-slow-lags.html

 

Marlon Ceballos.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

Hi Marlon,

Thanks for the link.  I tried all of those suggestions and performance improvements but to no avail.  The only 'limitation' I have is that the SSD in my device is effectively program and scratch as there is only one storage device.   Having said that, PS was working perfectly well until recently with that hardware setup.

 

To give an example, I just started PS, created a new blank document of about 2000x1500.   It probably took 30 seconds for the page to appear.   That can't be right?

 

Many thanks,

Mark.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Just to follow up on my own post, I finally managed to get ALL the devices we were having problems with running at what seems to be normal speed.

 

Simply untick the 'Use Graphics Processsor' on the Preferences/Performance tab, even if PS says it detects and supports the GPU.   

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines