Placed Illustrator files not scaling proportionally

Community Beginner ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

I'm placing illustrator files into my Photoshop document.  The images are perfectly round.

 

However, in Photoshop, *some* are warped. I can place a circle shape over them within Photoshop and see clearly that the circles are warped (i.e. taller than the width), but when I hit CTRL+T to Transform, I can see from the pixel dimensions in the top bar that they are identical in width and height.

 

Another issue I'm having with some of the other assets is that they DO look like perfect circles, but if I CTRL+T those, they immediately become warped within the Transform box (so, for instance, I can see on the left and right sides, empty space where the circles to not meet the bounding box).

 

Is this a bug?

TOPICS
Bug, Import and export, Problem or error

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

They should place in  Photoshop as vector smart objects layers with the correct  Illustrator aspect ratio. When you scale the layer are you constraining the transform to its AI aspect ratio . Your png showsboarders a on two side of the shape?

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Hello, in illustrator, check in outline view (CTRL+Y) if you are not adding other very small items like a rogue anchor point.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Hey, thanks for the reply.  Yes I've double-checked there's not some rogue element in the original file but there definitely isn't.  In honestly I didn't actually do any drawing in the Illustrator file - all the files are simple Pie Charts created using the Graph tool - there aren't any manually drawn objects in them at all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

To me it looks like there is something behind/hidden from the AI object. Did you check that?

Some filter/effect, empty object etc.

 

As mentioned by @JJMack also make sure that the placement is a VECTOR SMART OBJECT.

 

But it don't think that this is a bug…

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

LATEST

Well okay what do you mean by "make sure that the placement is a VECTOR SMART OBJECT"?  I create the file in Illustrator, and save it as a .AI file (didn't see any point in saving as EPS) , then I go to Photoshop, Place Linked... and select my file.

 

I get the dialogue box "Open as Smart Object", I select the 'page' (which is the only page) and in thje options it defaults to Crop To: Bounding Box, which I never change...

 

And that's all I do.  Is something here not the 'right' way?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines