Problem with merging layers. Image changes.

New Here ,
Mar 29, 2021 Mar 29, 2021

Copy link to clipboard

Copied

Looking for help!

 

I’ve found out that when I merge layers photoshop changes my image and eats my stars 😳 I’ve never had this problem before so I’m confused.

 

Please watch video.

 

What I’ve already tried with no luck:

 

Merged all different ways possible.

Saved file without merging the layers but discarding during “save as” process.

Tried different kinds of adjustment masks (Raya pro, TM panel, hand made lights/darks, simple adjustment without masking). Different quantity of them as well.

Reinstalled photoshop. Updated to the latest version.

Played with different image modes and color profiles (8 bits/16 bits, pro photo/rgb).

Googled.

 

I’ve got this problem on all my images not just this one and this is not a monitor problem as when I print my stars are not there.

 

I hope it’s possible to see the problem on the video!

 

https://youtu.be/IfDLnYHNGaw

TOPICS
Bug, Mac, Problem or error

Views

466

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 29, 2021 Mar 29, 2021

Copy link to clipboard

Copied

Could you please post screenshots of the layered and flattened image taken at View > 100% with the pertinent Panels (Toolbar, Layers, Options Bar, …) visible? 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

Will do it later today, thank you! But when I checked before the result was the same on 100% so it doesn't seem to be monitor related issue.

 

Yesterday I've sent the file to my friend and we opened it during video call. He has stable result, the image stays the same after merge! (We test both on 100% and fit to view zooms). We tried different ways of merging and everything works.

 

So now I think it could be some setting in my photoshop that is doing this. But have no idea what exact setting it may be...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

IME this can happen when you have nested layers, or smart objects that are not processed in the right order when merged.  My workaround is to select the upper most layer, and a copy merged layer (Shift Ctrl Alt E).  This adds a copy merged layer to the top of the stack, and has always displayed as it should.   You could also select all the layers and make them a smart object, but that still has a chance of failing.  Not often, but it does happen.  For me maybe four times in twenty five odd years.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

I've tried as a test to merge simple adjustment layers, I've made one exposure adjustment layer (without any masking) and curves layers (without masking as well). Merged all three, also tried to merge two (background plus one adjustment), the result is the same.

 

And yes, I'm merging the way you describe(it's my usual way to merge) but also tried "flattern", "merge visible" and other ways of merging. Nothing changes (

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

»Will do it later today, thank you! But when I checked before the result was the same on 100% so it doesn't seem to be monitor related issue.«

If there is no difference between layered and merged at View > 100% then there is no difference and what you are seeing probably are previewing issues owed to caching. 

cacheIssue50Percent.pngcacheIssue100Percent.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

I have the same change on printed image, so doesn't seem to be any preview issue, it is obviously there and stays there on paper (

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

What are you talking about exactly  – printing the layered image produces a different result than printing the merged image? 

 

Please post the requested screenshots. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

No.

 

I merge the image after final adjustments, it changes it appearance as we see on screenshot and video. When I print this merged image it looks the same as the merged one on screen (changed as well). I just write about printing to say that it's monitor or appearance issue as what I see on screen is what I see on paper.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

The video is not relevant (also it did not display here), I asked for screenshots. (edited)

 

»When I print this merged image it looks the same as the merged one on screen (changed as well).«

That would mean that what I stated is correct. 

The view you saw on screen for the layered image just suffered from the described preview issues. 

View > 100% is what counts. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

potamcha, this is on-screen resampling. You must view at 100%, which maps exactly one image pixel to exactly one screen pixel.

 

Try to visualize this example: a three-by-three pixel checkerboard pattern, crisp black and white, zoomed out on screen, so that there is only one screen pixel to represent it. Right. You get one gray screen pixel.

 

This is all about pixels. A starry night is like an extremely noisy image. You need to see every pixel to get a true representation. And you do that by viewing at 100%.

 

Now - this can bite you if you have layers and adjustments. For performance reasons, Photoshop keeps a cache of progressively downscaled versions. This is known as the image pyramid. When you zoom out, Photoshop goes to the cache and retrieves the appropriate smaller version, and puts that up on screen.

 

But it also uses this cached and smaller version for all the blending previews and adjustment previews. And this is where it bites you, because the small version is not a true pixel representation. It has a lot of intermediate blended values that aren't really there in the original data. This is the checkerboard turning gray. And so you get an incorrect preview.

 

When you merge the layers, however, the full data are merged. And that may give a different result for each pixel.

 

Bottom line - always, always, always view at 100% for a reliable preview. It should be in your blood. You should press ctrl+1 by habit, every time you need an accurate preview.

 

For a "normal" photograph this doesn't matter. But a starry sky isn't a normal image - it's technically pure noise.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

By the way: The old work-around of setting Cache Levels to 1 does not work anymore. 

The Bug has been acknowledged but remains, as far as I know, unfixed. 

https://feedback.photoshop.com/conversations/photoshop/photoshop-impossible-to-set-cache-levels-to-1...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 31, 2021 Mar 31, 2021

Copy link to clipboard

Copied

Yes, I noticed. If you try, it bounces right back.

 

And actually I don't even see it as a workaround. This should have been a genuine option in preferences, for those with hardware to match, and it should have been called something sensible like Generate Previews From Full Image Data.

 

In InDesign you can set display quality to low/normal/high with a performance tradeoff. Everybody seems to find their way around that setting. No reason to think it wouldn't work in Photoshop.

 

Imagine how much easier these questions would be if we could just point these night-sky-shooters to a setting in preferences, with a warning that it might affect performance.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 31, 2021 Mar 31, 2021

Copy link to clipboard

Copied

No argument there, it should be possible to set the Cache Level to 1 and be done with with that … 

 

I suspect the change was unintentional and should therefore be worth the resources to be fixed – but it affects so few people that the contrary decision was arrived at. 

For longtime Forum regulars it probably seems like a recurring issue but how often does it really come up – once a month or thereabouts? 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines