Problems with displaying masked images

Community Beginner ,
Nov 23, 2020

Copy link to clipboard

Copied

My masked images are not displaying correctly in RGB. When I convert to cmyk all is fine. The mask thumbnail displays correctly in the layers panel but not on the actual image. The image is fine as in if I save it and place into Indesign the masking is correct, but this problem is obviously making mask refinement impossible working in RGB. I have hobbled along with this problem for a while – it started with Photoshop 2019 but I could get round this by working in v2018 when required. Since upgrading to Catalina though my 2018 version won't launch. Currently using Photoshop 2021. Is this a hardware / graphics issue, or software. Screenshots attached of problems and my hardware set up (2014 imac – works absolutely perfectly for everything else). Hope someone can help!Screenshot 2020-11-23 at 12.59.14.pngScreenshot 2020-11-23 at 12.51.33.pngScreenshot 2020-11-23 at 12.51.16.png.

Correct answer by IngridHn | Community Beginner

In the advanced settings the Drawing Mode was set to Basic. I changed this to Normal – relaunched and it is now displaying perfectly. Thank you so much – I love you!!

TOPICS
Problem or error

Views

31

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Problems with displaying masked images

Community Beginner ,
Nov 23, 2020

Copy link to clipboard

Copied

My masked images are not displaying correctly in RGB. When I convert to cmyk all is fine. The mask thumbnail displays correctly in the layers panel but not on the actual image. The image is fine as in if I save it and place into Indesign the masking is correct, but this problem is obviously making mask refinement impossible working in RGB. I have hobbled along with this problem for a while – it started with Photoshop 2019 but I could get round this by working in v2018 when required. Since upgrading to Catalina though my 2018 version won't launch. Currently using Photoshop 2021. Is this a hardware / graphics issue, or software. Screenshots attached of problems and my hardware set up (2014 imac – works absolutely perfectly for everything else). Hope someone can help!Screenshot 2020-11-23 at 12.59.14.pngScreenshot 2020-11-23 at 12.51.33.pngScreenshot 2020-11-23 at 12.51.16.png.

Correct answer by IngridHn | Community Beginner

In the advanced settings the Drawing Mode was set to Basic. I changed this to Normal – relaunched and it is now displaying perfectly. Thank you so much – I love you!!

TOPICS
Problem or error

Views

32

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 23, 2020 0
LEGEND ,
Nov 23, 2020

Copy link to clipboard

Copied

To verify if it might be a GPU-driver-issue try turning off »Use Graphics Processor« in the Performance Preferences (Photoshop > Preferences > Performance > Graphic Processor Settings) and restarting Photoshop – does it have any bearing on the issue? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Community Beginner ,
Nov 23, 2020

Copy link to clipboard

Copied

It makes no difference – exactly the same result.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
LEGEND ,
Nov 23, 2020

Copy link to clipboard

Copied

Please try changing the Advanced Settings (and again restarting Photoshop). 

 

Do you still have Photoshop 2020 installed? Otherwise you could re-install it. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
Community Beginner ,
Nov 23, 2020

Copy link to clipboard

Copied

In the advanced settings the Drawing Mode was set to Basic. I changed this to Normal – relaunched and it is now displaying perfectly. Thank you so much – I love you!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
LEGEND ,
Nov 23, 2020

Copy link to clipboard

Copied

I am surprised, though; I would have expected »dialing down« the settings might help, not »dialing them up« … well, Photoshop can be full or surprises. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 1