Highlighted

PS CC 2018 Brush Lag/Brush Delay?

New Here ,
May 10, 2018

Copy link to clipboard

Copied

Just recently, I bought a subscription to creative cloud, for the sole purpose of using Photoshop. As a digital artist, it's been frustrating having to deal with the brush lag/delay, whilst having attempted to troubleshoot the issue for hours.

Solutions I've tried that do not fix the Lag/Delay:

-Turning off smoothing

-Lowering/Increasing the spacing of a brush

-Changing to basic mode

-Increasing/Decreasing Memory usage

-Lowering Cache Levels, Cache Tile Size, or History States

-Turning off rulers (I keep my rulers off at all times.)

Although the Brush Lag is faint, it's noticeable and breaks the flow of drawing and has me resorting to my other programs.

I've used the earlier version of PS CC 2017 on a lower end laptop in the past and had no issues.

Is this an issue, we can look forward to being fixed in the near future with an update? Or is it an issue on my end?

Help/Advice would be appreciated!

Thank you!

Thank you for the information, I do not think it has to do with the secondary monitor, however, I believe the issue is related to the GPU.

Could you please try deselecting "Use Graphics Processor" located in Photoshop's Preferences > Performance, then relaunch Photoshop and let us know if it helps?

Views

11.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PS CC 2018 Brush Lag/Brush Delay?

New Here ,
May 10, 2018

Copy link to clipboard

Copied

Just recently, I bought a subscription to creative cloud, for the sole purpose of using Photoshop. As a digital artist, it's been frustrating having to deal with the brush lag/delay, whilst having attempted to troubleshoot the issue for hours.

Solutions I've tried that do not fix the Lag/Delay:

-Turning off smoothing

-Lowering/Increasing the spacing of a brush

-Changing to basic mode

-Increasing/Decreasing Memory usage

-Lowering Cache Levels, Cache Tile Size, or History States

-Turning off rulers (I keep my rulers off at all times.)

Although the Brush Lag is faint, it's noticeable and breaks the flow of drawing and has me resorting to my other programs.

I've used the earlier version of PS CC 2017 on a lower end laptop in the past and had no issues.

Is this an issue, we can look forward to being fixed in the near future with an update? Or is it an issue on my end?

Help/Advice would be appreciated!

Thank you!

Thank you for the information, I do not think it has to do with the secondary monitor, however, I believe the issue is related to the GPU.

Could you please try deselecting "Use Graphics Processor" located in Photoshop's Preferences > Performance, then relaunch Photoshop and let us know if it helps?

Views

11.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 10, 2018 0
Adobe Employee ,
May 14, 2018

Copy link to clipboard

Copied

Hi Ronaldm,

We're sorry to hear about Brush lag in Photoshop, could you please let us know which exact version of Photoshop you're working on and which operating system are you using?

Could you please try resetting the preferences of Photoshop and let us know if it helps with the issue?

Preferences in Photoshop

Regards,

Sahil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
New Here ,
May 14, 2018

Copy link to clipboard

Copied

I'm using the current PS CC 2018, on Windows 10.

And I've reset the preferences, and there doesn't seem to be any change.

Would working on more than 1 monitor be an issue? I use a display tablet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2018 0
Adobe Employee ,
May 25, 2018

Copy link to clipboard

Copied

Thank you for the information, I do not think it has to do with the secondary monitor, however, I believe the issue is related to the GPU.

Could you please try deselecting "Use Graphics Processor" located in Photoshop's Preferences > Performance, then relaunch Photoshop and let us know if it helps?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2018 0
New Here ,
May 25, 2018

Copy link to clipboard

Copied

I followed your instructions, and there seems to be an improvement!

The brush lag has decreased significantly, although there still seems to be a small split second tick before the brush stroke appears.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2018 0
New Here ,
Jun 11, 2018

Copy link to clipboard

Copied

I too have been having this issue since I updated

seriously Adobe - this is not acceptable !!

as A professional retoucher this is badly affecting my speed, so also causing a loss in profitability

the brush tool is 'the' most commonly used tool in photoshop - how can it be that this doesn't work right now !!!!!!!

I've trawled the forums and tried all the fixes

turned off smoothing,

reset tool

reset / renamed preferences

and just turned off the "use graphics processor" option and this hasn't helped either

Running on

Mac pro late 2013

3.7 quad core intel xeon e5

16gb memory

Amd Firepro D500 3072mb

OsX El Capitan 10.11.6

I'm going to have to downgrade now

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2018 1
Community Beginner ,
Aug 05, 2018

Copy link to clipboard

Copied

No one should have to mess with the brushes themselves. That doesn't seem to be the issue. I poked around to a lot of the forum questions related to this issue. I went back to the version I last had no issues with and checked the performance settings. Many suggested turning it off & on. But, the latest update had changed the settings whereas the earlier version I went back to I noted the settings. Then went back to the latest update and made sure the settings matched.

So it seems that the latest update had turned off some of the checked items in the advanced area of the performance preferences and changed the Drawing Mode to Basic.

To check out those settings, go to Photoshop Preferences > Performance > Graphics Processor Settings: Advanced Settings >

Make sure all Advanced Settings are checked and the Advanced Drawing Mode is selected instead of Basic or Normal. In the Performance area, also make sure you are allowing Photoshop to use enough memory. Mine is set to 70%. I use Photoshop deeply so it's important for it to work properly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 05, 2018 1
New Here ,
Sep 10, 2018

Copy link to clipboard

Copied

I'm a photogrpher and I have the same problem of the original post since the first update to Photoshop CC2018 and for me it is impossible to work with such a serious handicap.

I tried and followed several discussions about it and I tried several times without solving.

For now I'm still working on Photoshop CC 2017 without being able to take advantage of improvements brought to CC 2018!!!!!

I hope that SOON there will be a way to fix this problem!!!!!!

Thank you!

Windows 10

intel core i5 6600

Nvidia geforce GTX 1060 6Gb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2018 1
New Here ,
Aug 01, 2019

Copy link to clipboard

Copied

Hi, did you fix the problem . For me it was defiantly turning off the smoothing in both Brushes and Erase.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 01, 2019 2
New Here ,
Dec 09, 2019

Copy link to clipboard

Copied

This worked for me too

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 09, 2019 0
New Here ,
Aug 16, 2020

Copy link to clipboard

Copied

Thank you! This worked for me also.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 16, 2020 0
Community Beginner ,
Sep 27, 2018

Copy link to clipboard

Copied

I had the same issue, but I think I fixed it on my side (kind of). If you select your brush, you will have a folder that is the "shape parameters", there you have a list of characteristics with box that you can check or uncheck. The parameter "smoothness" was the one that made my brush delayed. (sorry I don't know if the words are correct I am translating from french) It worked for me! !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2018 1
New Here ,
Jun 17, 2020

Copy link to clipboard

Copied

This suggestion worked for me. I tried all other performance setings and recommendations for about 40 min. Frustrated... This changed the brush speed for me! Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2020 0
Advocate ,
Sep 27, 2018

Copy link to clipboard

Copied

Hi Ronaldm,

1 step is:-  Go to Edit then Select Purge and the select all. After doing this your all photoshop problems will be fixed. It will reset your photoshop.

2 step is:-  Turn off the Scattering option inthe Brush tool panel.

Hope so it will fixed your brush lag.Screenshot_3.pngScreenshot_4.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2018 0
New Here ,
Oct 26, 2019

Copy link to clipboard

Copied

Hello,

 

I got in touch with Kuldeep from Adobe and he helped me resolve this exact issue. I will provide a link below to the steps we went through to resolve the issue.

 

https://helpx.adobe.com/in/photoshop/kb/tablet-support-faq-photoshop.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 26, 2019 0