PS changing the bounding box is either a bug or the worst feature ever

Community Beginner ,
Dec 01, 2020

Copy link to clipboard

Copied

When postprocessing 3D renderings frame by frame in photoshop, PS will change the bounding box on images with transparent background from original render size (transparent areas included) to a somewhat inaccurately defined and lackluster, if not pointless area around what I assume PS thinks is the object of interest.

 

This is driving me crazy because it makes things like batch aligning hundreds of images, making use of predefined canvas area, accurately layering frames, etc. completely impossible.

 

The attached images show this. First, the full bounding box as it appears when placing & embedding the immage. As soon as you commit by clicking the checkmark/enter, it will reduce the bounding box, making the image completely useless for these purposes.

 

If this is intentional, please allow us to turn this off and revert to the old bounding box that simply maintains the full size of the image at all times.


And if anybody knows how to turn this efficiency-culling "feature" off forever, please tell me how to do that.

 

Cheers,
Mark

PS v2021 latest update
PC: not the issue. that thing is an absolute beast.

TOPICS
Bug, Import and export, Problem or error, Windows

Views

34

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PS changing the bounding box is either a bug or the worst feature ever

Community Beginner ,
Dec 01, 2020

Copy link to clipboard

Copied

When postprocessing 3D renderings frame by frame in photoshop, PS will change the bounding box on images with transparent background from original render size (transparent areas included) to a somewhat inaccurately defined and lackluster, if not pointless area around what I assume PS thinks is the object of interest.

 

This is driving me crazy because it makes things like batch aligning hundreds of images, making use of predefined canvas area, accurately layering frames, etc. completely impossible.

 

The attached images show this. First, the full bounding box as it appears when placing & embedding the immage. As soon as you commit by clicking the checkmark/enter, it will reduce the bounding box, making the image completely useless for these purposes.

 

If this is intentional, please allow us to turn this off and revert to the old bounding box that simply maintains the full size of the image at all times.


And if anybody knows how to turn this efficiency-culling "feature" off forever, please tell me how to do that.

 

Cheers,
Mark

PS v2021 latest update
PC: not the issue. that thing is an absolute beast.

TOPICS
Bug, Import and export, Problem or error, Windows

Views

35

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 01, 2020 0
LEGEND ,
Dec 01, 2020

Copy link to clipboard

Copied

First off: This is a user Forum, so you are not really addressing Adobe here, even though some Adobe employees thankfully have been dropping by.

 

Just turn off »Show Transform Controls« (which is not about what »PS thinks is the object of interest« but simply about the pixels with actual content) and use Edit > Free Transform (cmd-T), that should get you the actual bounding box of the Smart Object. 

 

And: Compliments on placing the images as Smart Objects in the first place! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2020 0
Community Beginner ,
Dec 01, 2020

Copy link to clipboard

Copied

Thank you for your reply. Unfortunately this doesn't seem to work. Deactivating transform controlls and instead transforming/translating via ctrl+T still just yields the reduced bounding box. Further, it doesn't actually show all the pixels with actual content. I know this because some areas below and left of the knife are cut off, even though there are transparent shadows in that area. Do you happen to have any other suggestions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2020 0
Community Beginner ,
Dec 01, 2020

Copy link to clipboard

Copied

You know what, I found one of the possible causes. Since I am preparing these renderings for web presentations, I am working in 8bit mode. The renders themselves however have a depth of 32bit. This is what could cause PS not to detect certain pixels because the threshold for transparency in 8bit may just be too large.

However, the image still has an inherrent size and proportion, which I'd like PS to stick to. This behaviour is recent I believe, I switched from version 2019 and did not have this problem back then.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2020 0
LEGEND ,
Dec 01, 2020

Copy link to clipboard

Copied

Could you provide the file for testing? 

I created an 8bit file with a placed 32bit Smart Object and cmd-T gets me the correct (comlpete) Bounding Box. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2020 0