Highlighted

quick selection tool not selecting

Community Beginner ,
Jan 16, 2016

Copy link to clipboard

Copied

(Cloud user of Photoshop CC 2015) The quick selection tool is not working properly. Either it looks like it is selecting but the selection disappears as soon as I un-click my mouse. Same for the magic wand.

In addition, if I do manage to make and see a selection, I cannot fill with a solid colour. Only the outline gets coloured.

The markee tool works as normal.

I have reset my tools, and no change.

Can someone help please?

Topics

How to

Views

28.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

quick selection tool not selecting

Community Beginner ,
Jan 16, 2016

Copy link to clipboard

Copied

(Cloud user of Photoshop CC 2015) The quick selection tool is not working properly. Either it looks like it is selecting but the selection disappears as soon as I un-click my mouse. Same for the magic wand.

In addition, if I do manage to make and see a selection, I cannot fill with a solid colour. Only the outline gets coloured.

The markee tool works as normal.

I have reset my tools, and no change.

Can someone help please?

Topics

How to

Views

28.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Jan 16, 2016

Copy link to clipboard

Copied

Check the tool option bar settings for what your sampling and othe options set

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 16, 2016

Copy link to clipboard

Copied

Hello JJMack: this is what I get... looks normal

(hmmmm, can't upload the screen shot 😕 )

Anyway, it looks as it should. I don't understand why this is not working (no sampling is ticked, for example)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 16, 2016

Copy link to clipboard

Copied

Is it selecting all of the pixels? (Is there a marching ants border on the edges of the document?)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 16, 2016

Copy link to clipboard

Copied

Yes, there is. but it only colouring the border/outline, not the full selection with the solid colour I requested. Very strange (and annoying)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 16, 2016

Copy link to clipboard

Copied

It sounds like a stroke is being made on a selection but that only happens via something Edit > Stroke on the menu bar. You'd want Edit > Fill.

You can't upload a screenshot? (Use the camera icon in the toolbar above where you compose your message here.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 16, 2016

Copy link to clipboard

Copied

I did Edit > Fill (not Stroke) which is why it is driving me mad. As for a pic, the uploader doesn't accept .tiff (whith Grab)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 16, 2016

Copy link to clipboard

Copied

converted the .tiff, here you can see.

PS fault.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 16, 2016

Copy link to clipboard

Copied

I know that the Quick Selection Tool tries to find pixel boundaries, so that may explain why you can't seem to fill the frame with that tool. But the Magic Wand Tool should select the area inside.

Try placing an image layer underneath the frame and try using the Quick Selection Tool again with the "Sample All Layers" option checked.

ON EDIT: You might want to use a solid, contrasting color to the frame like black for maximum effect.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Enthusiast ,
Jan 16, 2016

Copy link to clipboard

Copied

mine was doing that and I reset the preferences file. seems to have fixed it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 18, 2018

Copy link to clipboard

Copied

it seems you have a color background , try to lock the background , this should be your issue if you still have it

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 16, 2018

Copy link to clipboard

Copied

I had the exact same issue - while using the Quick Selection tool, the selection marquee disappeared as soon as I let go of the mouse button. If I clicked on the selection again, the marquee re-appeared as I held the mouse button, and it had the previous Quick Selection there - so the selection was still there, it just disappeared as soon as I let go of the mouse button.

In my case, I discovered this behavior while working on a simple file consisting of two layers. I was working on the top layer - the active layer. The *inactive* bottom layer was turned off (that is, the layer visibility [the eyeball icon] was unchecked in the Layers panel). After a few minutes of trying to figure it out, I activated the visibility of the 2nd layer. Voila! the selection marquee re-appeared, and the tool and the resulting selection marquee is behaving normally again.

This seems like new behavior to me - I am sure that in times past, I have successfully made a quick selection on a multilayered file with one or more of the inactive layers' visibility turned off.

Adobe, was this the result of some update, or some combination of keystrokes?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 15, 2019

Copy link to clipboard

Copied

Hello,

go to Preferences/Performance/Collum Grafic Procesor Setting - Advanced Settings and try uncheck Anti-alias Guides and Patch

Good Luck

Peter

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 26, 2020

Copy link to clipboard

Copied

Thank you so much! This helped a lot!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 08, 2020

Copy link to clipboard

Copied

I had the same problem and discovered I had inverted the selection in the step prior. Photoshop was doing what I told it, but the inverse action of what I wanted. Quick fix: Just swap the - and + functions. Presto!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 06, 2020

Copy link to clipboard

Copied

It is very easy. Just click on sample all layers. I had the same problem but it got solved in under a secend

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...