Highlighted

Razer Color Profile Issues on Windows

Contributor ,
Sep 03, 2020

Copy link to clipboard

Copied

My Razer Blade laptop came with a pre-installed ICC Profile that makes things look calibrated and correct to my eyes.
ColorManagement.png

I read another response in this forum that recommended adding an sRGB profile and making it the default. When I do that, the whites turn a horrid shade of bright blue, as the monitor itself looks pretty terrible uncalibrated. I need this calibration profile enabled to see more accurate colours (so I removed the sRGB and my settings are currently the same as the screenshot above)

Inside of Photoshop, everything is set to the default color management and I work in sRGB for the web. When I open an sRGB document, the colours look off unless I turn on Proof Colors > Monitor Profile.

When I save for web, they all look correct in the preview pane, and come out correct in the end. Everything looks correct except for my working space (unless I turn on proof colours).

 

How do I keep the calibrated profile active for every non-Photoshop app, but get my images to look correct inside photoshop without having to proof?

Note: This laptop comes with both the integrated graphics card (it's named in the screenshot) and a GeForce one, too. Photoshop is set to be accelerated by the RTX card.

 

Edit: forgot to mention: Windows 10 is fully up to date as of today, and so is Photoshop.

TOPICS
How to, Windows

Views

43

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Razer Color Profile Issues on Windows

Contributor ,
Sep 03, 2020

Copy link to clipboard

Copied

My Razer Blade laptop came with a pre-installed ICC Profile that makes things look calibrated and correct to my eyes.
ColorManagement.png

I read another response in this forum that recommended adding an sRGB profile and making it the default. When I do that, the whites turn a horrid shade of bright blue, as the monitor itself looks pretty terrible uncalibrated. I need this calibration profile enabled to see more accurate colours (so I removed the sRGB and my settings are currently the same as the screenshot above)

Inside of Photoshop, everything is set to the default color management and I work in sRGB for the web. When I open an sRGB document, the colours look off unless I turn on Proof Colors > Monitor Profile.

When I save for web, they all look correct in the preview pane, and come out correct in the end. Everything looks correct except for my working space (unless I turn on proof colours).

 

How do I keep the calibrated profile active for every non-Photoshop app, but get my images to look correct inside photoshop without having to proof?

Note: This laptop comes with both the integrated graphics card (it's named in the screenshot) and a GeForce one, too. Photoshop is set to be accelerated by the RTX card.

 

Edit: forgot to mention: Windows 10 is fully up to date as of today, and so is Photoshop.

TOPICS
How to, Windows

Views

44

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 03, 2020 0

Have something to add?

Join the conversation