Highlighted

Save as copy - can't turn off

Community Beginner ,
Jun 22, 2017

Copy link to clipboard

Copied

I have searched the forum and seen several discussions on this topic but none that helps me.

I edit all my website images in Photoshop CC 2017 and save these images in case I need to re-edit them later. I then resize and convert them to JPGs with the same name as the original but with a .jpg extension.

Regardless whether I do this with a "Save As" or "Automate->Batch", the "save as a copy" selection is grayed out and can't be changed. I end up with the files I want but with the word "copy" in the filename. I can't find any way to turn this action off. I have read all the other topics talking about levels, layers and the such but that is immaterial to me. I have the original PSD file and the resultant correct JPG file. The only thing that is wrong is that stupid word "copy" in the file name. I have found nothing in Preferences that allows this to be turned off.

I have to manually remove the work "copy" from every file name. Sometimes I do hundreds of files at a time and end up using a batch script to rename all the files.

I'm considering buying a third party conversion utility that does the conversion without word "copy" in the filename.

Is there anyway to turn off this action?

Adobe Community Professional
Correct answer by Jeff Arola | Adobe Community Professional

Just so were on the same page, your doing a Flatten Image and not Merge Layers before saving as a JPEG?

Views

11.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Save as copy - can't turn off

Community Beginner ,
Jun 22, 2017

Copy link to clipboard

Copied

I have searched the forum and seen several discussions on this topic but none that helps me.

I edit all my website images in Photoshop CC 2017 and save these images in case I need to re-edit them later. I then resize and convert them to JPGs with the same name as the original but with a .jpg extension.

Regardless whether I do this with a "Save As" or "Automate->Batch", the "save as a copy" selection is grayed out and can't be changed. I end up with the files I want but with the word "copy" in the filename. I can't find any way to turn this action off. I have read all the other topics talking about levels, layers and the such but that is immaterial to me. I have the original PSD file and the resultant correct JPG file. The only thing that is wrong is that stupid word "copy" in the file name. I have found nothing in Preferences that allows this to be turned off.

I have to manually remove the work "copy" from every file name. Sometimes I do hundreds of files at a time and end up using a batch script to rename all the files.

I'm considering buying a third party conversion utility that does the conversion without word "copy" in the filename.

Is there anyway to turn off this action?

Adobe Community Professional
Correct answer by Jeff Arola | Adobe Community Professional

Just so were on the same page, your doing a Flatten Image and not Merge Layers before saving as a JPEG?

Views

11.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 22, 2017 0
Adobe Community Professional ,
Jun 22, 2017

Copy link to clipboard

Copied

What happens if you Flatten your document before saving as a JPEG?

Layer>Flatten Image

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Community Beginner ,
Jun 22, 2017

Copy link to clipboard

Copied

Same thing. Still wants to save as a copy.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Adobe Community Professional ,
Jun 22, 2017

Copy link to clipboard

Copied

What operating system are you using?

Is your photoshop cc 2017 updated to version 2017.1,1?

From inside photoshop go to Help>System Info and top line is the photoshop version.

Anyway, here on windows 10 and cc 2017.1.1 if i have a layered psd file saved in some folder and open that layered psd in photoshop, flatten the image and save as a jpeg into the same location as the psd with the same name it does not add Copy to the name.

Do you already have another jpeg in your folder of the same name?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
New Here ,
Nov 09, 2020

Copy link to clipboard

Copied

This "new" feature isn't helpful as I don't want to:

  1. Save my file
  2. Flattten the image
  3. Save my layer (png or jpg)
  4. Re Open the saved file.

 

Not helpful.  Waste of my time.

Please restore the previous way without having to save as a copy.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2020 1
Community Beginner ,
Nov 09, 2020

Copy link to clipboard

Copied

Why the sh1t did they even introduce it? It doesn't do it with multi-layers when you save a GIF?

 

Or a PNG

 

Or a TIFF

 

It's MENTAL!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2020 0
New Here ,
Nov 29, 2020

Copy link to clipboard

Copied

After flattening your image, try under "image" then "mode" change to 8 bits/channel

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 29, 2020 0
Community Beginner ,
Jun 22, 2017

Copy link to clipboard

Copied

2017.1.1 20170425.r.252 2017/04/25:23:00:00 CL 1113967  x64

Windows 10 Pro Version 1703 OS Build 15063.413

No other JPGs in the save location. Doesn't matter where I try to save it, I always get the "Save as a Copy" checked and disabled in the save dialog.

It doesn't matter whether I merge all the layers or not. In fact I tried one that has only a single layer and got the same result.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Adobe Community Professional ,
Jun 22, 2017

Copy link to clipboard

Copied

Just so were on the same page, your doing a Flatten Image and not Merge Layers before saving as a JPEG?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Community Beginner ,
Jun 22, 2017

Copy link to clipboard

Copied

Aha. I thought merging and flattening did the same thing. When I googled it before adobe said "Flattening is merging all visible layers into the background layer to reduce file size." and on the same page it shows commands for both merging and flattening with merging showing first. https://helpx.adobe.com/photoshop/key-concepts/flattening.html

I'm not sure what the difference is between flattening and merging all (except that flattening discard non-visible layers) but when I flatten it I can save as a JPG without the "copy" and when I merger all (after discarding non-visible layers) it put "copy" in the filename so a flattening I will go.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Community Beginner ,
Jun 22, 2017

Copy link to clipboard

Copied

I just rewrote my Action to resize, flatten and resave as a JPG.

Ran it with 75 files and it worked great.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Adobe Community Professional ,
Jun 22, 2017

Copy link to clipboard

Copied

Merging layers merges all the layers into one layer, but if you don't have a Background layer you still won't after merging, so you still have "Regular Layers" and that's why Copy is added because JPEGs don't support layers even if it is just one layer, it's not a Background Layer.

Flatten Image merges all the layers into a Background Layer which is the only kind of "Layer" supported by the JPEG file format.

Don't worry it's a little bit of a weird concept to grasp.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Community Beginner ,
Jun 22, 2017

Copy link to clipboard

Copied

Thanks for the help. It doesn't quite make sense to me but now that I know what to do I'll keep on trucking.

What's weird is that I have been doing this for many years (since Photoshop 6.0) and have done many thousands of images. I haven't done any for several months and don't remember if I used an external converter for this (I have Image Converter Plus) or used Photoshop. I never had this issue before.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Community Beginner ,
Apr 22, 2018

Copy link to clipboard

Copied

Hi,

I have the same problem and flattening before saving is not helping. What I do:

1. Have a document with several layers.

2. I create an action to do: Select Layers > Flatten Image, then Save As: Save as JPEG.

The word "copy" is added to the end of the file every time I run the action. It's very annoying.

I appreciate any help.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 22, 2018 0
Adobe Community Professional ,
Apr 22, 2018

Copy link to clipboard

Copied

What operating system and version of photoshop are you using?

Could you post a screenshot of the action?

What is the Color Mode and Bit Depth of the documents?

For example, are any 16 bits/channel?

Does the action have With Copy in the Save As step like shown below?

save.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 22, 2018 0
New Here ,
May 06, 2018

Copy link to clipboard

Copied

Hi,

Well my action was showed up exactly like your screenshot. And I'm using mac OS, sRGB, & 16 bits also for editing.

Any help to shut this "save as copy" down? Because it seems I cant turn it off as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2018 0
Adobe Community Professional ,
May 06, 2018

Copy link to clipboard

Copied

In your action flatten and convert to 8 bits/channel before saving as a Jpeg.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2018 1
New Here ,
May 06, 2018

Copy link to clipboard

Copied

Wow that's help! Wondering why I can't use 16 bits tho. Anyway thanks for ur answer!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2018 0
Adobe Community Professional ,
May 06, 2018

Copy link to clipboard

Copied

Jpegs don't support 16 bits/channel or layers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2018 0
Adobe Community Professional ,
May 06, 2018

Copy link to clipboard

Copied

In fact, to be absolutely clear, the jpeg specification basically doesn't support anything. All that is allowed is a flat, 8 bit array of pixels. Anything at all beyond that, and jpeg is no longer an option.

Few people realize this, and that's why we keep getting these questions. Jpeg is an incredibly restricted and limited file format.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2018 0
Explorer ,
Oct 06, 2019

Copy link to clipboard

Copied

I have the same problem with Photoshop CS6 (Win 10 Pro latest update 1903).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2019 0
Community Beginner ,
Dec 10, 2017

Copy link to clipboard

Copied

Just about the most irritating feature ever, having to first flatten. The save as copy function should always be available to uncheck. Shouldn't even be a default.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 10, 2017 2
New Here ,
May 15, 2018

Copy link to clipboard

Copied

Hi

I have the exacted same problem. But min do it with every adobe program, illustrator, indesign, photoshop - exept Adobe Animate.

Aaaand yes, its very annoying. Ive tired to seach the internet for several day and havent found anything.
And my collegae have the exact same computer, the same programs, same system, all the same - but the 'save as' problem is only happening on my computer ...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 15, 2018 0
Explorer ,
Jul 19, 2018

Copy link to clipboard

Copied

Hello,

I am also facing this problem.

I would like to save all kinds of files PSD / PDF / JPG etc and each time I try to save I have the "save as a copy" option and "layers" option both on and I cannot turn them off.

I have tried to find any settings that would disable these but without any luck.

I am using the latest update of both Windows 10 and Photoshop CC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 19, 2018 0
Participant ,
Jul 15, 2019

Copy link to clipboard

Copied

does this crazy bug doesn't have a solution? i am trying to save a jpg from a 8bit, flatten files   and all are "files must have a copy"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2019 0
Adobe Community Professional ,
Jul 15, 2019

Copy link to clipboard

Copied

To determine if layers is the issue:.

If your Layer panel looks like this, Layer 0 or any other name apart from Background, then the file really has layer information, which is not supported in the jpeg file format specification. So it has to be a copy.

Layer0.png

If it looks like this, with Background in italics, you have a genuinely flat file, and it has to be something else.

Background.png

That doesn't necessarily mean it's a "bug". It is much more likely that some other property in your file is not supported in the jpeg file format specification. That's a long list, as the jpeg format basically supports nothing at all except a flat 8 bit array of pixels, no extras.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2019 1
Adobe Community Professional ,
Jul 24, 2019

Copy link to clipboard

Copied

I'm thinking File > Export > as Jpeg would be an alternative. That function also eliminates the 8192 pixel cap that was in Save for Web.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2019 0
Adobe Community Professional ,
Jul 24, 2019

Copy link to clipboard

Copied

Indeed. This is exactly why Export (and Save For Web) is there in the first place. To save out a jpeg at all, you have to branch out a copy from the original file, for the reason I've repeated time and again in these threads: the jpeg specification allows virtually nothing of what you normally and routinely do to a file in Photoshop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2019 0