Highlighted

Save for web excluding file extension in output file

New Here ,
Nov 27, 2019

Copy link to clipboard

Copied

I'm using Photoshop 2020, newest update.

 

When saving for web (after choosing format, compression, etc.), the file name is selected, ready for me to either hit enter or type in a new name (all good so far). I type in the new name, and hit enter. The resulting file name is all good, but the extension is gone. Surely this is unexpected behaviour, an oversight? It can't be meant to be this way, that all files saved via "save for web" lack file extensions if you type in a new name? I'm annoyed.

 

As the screenshots below show, I have file extensions enabled in Finder.

https://imgur.com/a/5yevMOb

Topics

Problem or error

Views

289

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Save for web excluding file extension in output file

New Here ,
Nov 27, 2019

Copy link to clipboard

Copied

I'm using Photoshop 2020, newest update.

 

When saving for web (after choosing format, compression, etc.), the file name is selected, ready for me to either hit enter or type in a new name (all good so far). I type in the new name, and hit enter. The resulting file name is all good, but the extension is gone. Surely this is unexpected behaviour, an oversight? It can't be meant to be this way, that all files saved via "save for web" lack file extensions if you type in a new name? I'm annoyed.

 

As the screenshots below show, I have file extensions enabled in Finder.

https://imgur.com/a/5yevMOb

Topics

Problem or error

Views

290

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Nov 27, 2019

Copy link to clipboard

Copied

What version of macOS are you using?

 

Is it Catalina?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 28, 2019

Copy link to clipboard

Copied

I should have included that in my post, of course. I'm using Catalina. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 28, 2019

Copy link to clipboard

Copied

That seems to be issue with Catalina.

Until it's fixed you'll have to remember to append the file extension manually.

 

https://feedback.photoshop.com/photoshop_family/topics/save-for-web-bugs-on-macos-10-15-catalina

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 22, 2020

Copy link to clipboard

Copied

Same issue too. It really slows down work flow.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jun 18, 2020

Copy link to clipboard

Copied

Not fixed Version 21.2.0

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 18, 2020

Copy link to clipboard

Copied

Just sticking my oar in as well, still not fixed in 21.2.1, bumping for attention!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 18, 2020

Copy link to clipboard

Copied

This has come up "hundreds of times" since Catalina was released, however, nobody has been willing to see if exporting via a script resolves this issue. People just wait and hope that each new release resolves the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...