Spinning beachball PS 2020

Community Beginner ,
Jun 15, 2020

Copy link to clipboard

Copied

I am getting a 2-3 sec spinning beach ball on every function; crop tool, brush, save... even trying get a spinning beach ball when I select photoshop/about

I am only having issues with photoshop.

 

I reset preferences and all is good for about an hour then the spinning beach ball starts again.  

I have verified fonts, deleted Font cache

PS 21.1.3  

iMac (Retina 5K, 27-inch, 2019), 10.15.5

3.6 GHz 8-Core Intel Core i9

64 GB 2667 MHz DDR4

Radeon Pro Vega 48 8 GB

 

 

TOPICS
Crash or freeze, Performance, Problem or error

Views

563

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Adobe Community Professional , Jun 15, 2020
josephlavine Adobe Community Professional , Jun 15, 2020
This does sound odd. The first area that I suggest checking is to make sure you have enough RAM allocated and the Graphic Processor is checked. These are both listed under Photoshop > Preferences > Performance. You might also want to reset all defaults listed under Preferences > General. warmly/j 

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional ,
Jun 15, 2020

Copy link to clipboard

Copied

This does sound odd.

The first area that I suggest checking is to make sure you have enough RAM allocated and the Graphic Processor is checked. These are both listed under Photoshop > Preferences > Performance. You might also want to reset all defaults listed under Preferences > General. warmly/j 

Screen Shot 2020-06-15 at 6.59.32 AM.jpg

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Aug 14, 2020

Copy link to clipboard

Copied

Worked!

 

I just rest all of my preferences (yes I had to go back in a change everything back to normal) but this seemed to have solved it.

 

I have a feeling that PS imports the prefs from previous versions during install and there is a conflict.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 12, 2020

Copy link to clipboard

Copied

I've found the "guilty" pref, wich caused the beach ball lag. For me it was the User/Library/Preferences/Adobe Photoshop 2020 Settings/MachinePrefs.psp . I deleted it, and the beach ball lag has gone! This way all my settings remained.
Thanks for the tip to chuckszachta for resetting preferences!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 12, 2020

Copy link to clipboard

Copied

Sadly I am back to using 2018 again. This versions was still beach balling in a variety of scenarios, too many to list here. I will try the "MachinePrefs.psp" file and see if that helps. Let us know how you are doing a few days in.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 20, 2020

Copy link to clipboard

Copied

Still all good. I don't know deleting the "MachinePrefs.psp" works for everybody, but for me this helped.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 31, 2020

Copy link to clipboard

Copied

Deleting "MachinePrefs.psp" worked for a while, maybe 25hrs, just redeleted and will try again.  It is an odd issue because once it starts it affects most functions.  

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Vampren LATEST
New Here ,
Jan 12, 2021

Copy link to clipboard

Copied

Thank you for this fix. You have saved me hours of frustration at work!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 28, 2020

Copy link to clipboard

Copied

Deleting the "MachinePrefs.psp" did not work for me. I also allocatied 70% of my ram to Photoshop, dropped my history state count- down to 80(just for good measure), but still getting a beach ball. I did transfer my settings/preferences from the previous version of PS, so I will try resetting my preferences. Wish me luck!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 28, 2020

Copy link to clipboard

Copied

My machine specs just for reference for anyone who can help. Thank you.Screen Shot 2020-10-28 at 4.59.12 PM.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 29, 2020

Copy link to clipboard

Copied

UPDATE: Fixed the issue after resetting preferences and relaunching PS. Thank you!!!

 

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 10, 2021

Copy link to clipboard

Copied

For Photoshop 2021,

Preferences > General > Reset Preferences on Quit

Did the trick and solved the spinning ball lag for me.

Thanks for the thread!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more