Highlighted

The command SELECT is not currently available

New Here ,
Jan 19, 2016

Copy link to clipboard

Copied

I've installed a Greater Than Gatsby Action but cant run it because I get 'The command SELECT is not currently available. I tried running a default Action and get 'The command FEATHER is not currently available.'

I went back to PREFERENCES to check everything is in order. I cant find anything amiss. Can someone help please?

Capture.PNG

I had this exact same issue with an action I was using.  Look down the action list at the first "Select" command.  Make sure that your layer is named the same as what is in that command.  After that it should work.

TOPICS
Actions and scripting

Views

145.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

The command SELECT is not currently available

New Here ,
Jan 19, 2016

Copy link to clipboard

Copied

I've installed a Greater Than Gatsby Action but cant run it because I get 'The command SELECT is not currently available. I tried running a default Action and get 'The command FEATHER is not currently available.'

I went back to PREFERENCES to check everything is in order. I cant find anything amiss. Can someone help please?

Capture.PNG

I had this exact same issue with an action I was using.  Look down the action list at the first "Select" command.  Make sure that your layer is named the same as what is in that command.  After that it should work.

TOPICS
Actions and scripting

Views

145.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 19, 2016 4
Mentor ,
Jan 19, 2016

Copy link to clipboard

Copied

Hi

Seem a bit stupid of me to ask, but have you selected a layer (not lock) to run the action ?

Pierre

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 19, 2016 0
Most Valuable Participant ,
Jan 19, 2016

Copy link to clipboard

Copied

Have you tried singe stepping the action to see what condition the document is in when feather is not available? Have some pixel been selected to be feathered?

Your screen captures has no marching ants showing...

Step the other action and see why select is not available.  That is a common error message that action generated when the action is not well crafted.

Actions have dependencies.

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 19, 2016 1
New Here ,
Feb 22, 2018

Copy link to clipboard

Copied

Hi JJMACK, Are you able to talk me through this one? been reading a few posts but I'm feeling a bit dumb not being able to figure it out!

Thanks,

John

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2018 0
Most Valuable Participant ,
Feb 23, 2018

Copy link to clipboard

Copied

You have hidden the image tab in the screen capture you are most likely editing in 16 Bit color depth so the Filter Glass is not available

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 23, 2018 0
New Here ,
Feb 27, 2018

Copy link to clipboard

Copied

Hi! I'm sorry to bother you, but I'm a bit desperate. I need to send over 1,000 photos that I took this weekend of a volleyball event and I am trying to put 3 different logos on them with no success. That's the message I get every time. I tried different things and even putting just one logo at the time, but it is still not working. Been doing this since last night. Can you help?

Screen Shot 2018-02-27 at 11.26.50 AM.png

Screen Shot 2018-02-27 at 11.26.28 AM.pngScreen Shot 2018-02-27 at 11.26.39 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
Most Valuable Participant ,
Feb 27, 2018

Copy link to clipboard

Copied

Action have some dependencies you may need to have three different actions and it look link you may be using a watermark  with transparent borders and  may well have positioning problems for the bordered may well be primed during place or paste. If you image have different sizes and orientation you may also have sizing and position problems with action.  I have posted a script the will place in water marks based in the current document size.  You could modify it and create three scripts on for each of your logo. Record three one step action that use these scripts then batch the actions with the Images Processor Pro to create the three version of each image.  Scripts can use logic naming output files Actions have many limitations but are easy to record. So keep actions simple and use the  with features like menu file>Automate>Batch or Automate>Image Processor Pro, and Scripts like menu File>Scripts>Image processor.

http://www.mouseprints.net/old/dpr/PlaceWatermark.jsx  customize the firs few var  statements in the script. You can right click the link and save the script.

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
New Here ,
Feb 27, 2018

Copy link to clipboard

Copied

Thanks for the answer, but everything you said sounds like german to me lol I'm sorry, I tried to find a tutorial but i have no idea how to use scripts. I have done this before for a friend and never came across this issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
Most Valuable Participant ,
Mar 03, 2018

Copy link to clipboard

Copied

When you get the message look at the step in the action pannel and look at the document open in Photoshop and look ate what is the curreny target Why is the command not useable is the document perhaps 16bit color look atr the tab or image window info.

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2018 0
Engaged ,
Mar 09, 2018

Copy link to clipboard

Copied

Your recorded actions are a mess. E.g. there are 7 steps all selecting "Layer 2" in a row but there are no operations in between. At most you need ONE Select layer "Layer 2"

Any document you run your action against MUST have a layer named "Layer 1" and a layer named "Layer 2" or those select steps will fail as the dialog is showing you... Photoshop cannot select "Layer 1" in the current document. Indeed, it appears that document (the logo) has ONLY one layer, but you've covered it over so we can't see what the layer name actually is (most likely it is "Background"). The dialog is also covering over other steps, so we can't tell what may be going on with those.

In addition you have steps "Select Document -3" and "Select Document +3"... if in the course of your action you close and open documents, the ordering of those documents may change. It's not likely a problem here, just something worth pointing out.

Finally, you haven't expanded what "Set Current Layer" and other steps are actually doing, so we cannot tell what other problems your action may have introduced.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 09, 2018 0
New Here ,
Jan 18, 2020

Copy link to clipboard

Copied

Had this issue this morning. Have used this same action in the past with no issues until this morning.

 

1.) Make sure your bottom layer is named Background and it's locked.

2.) Create a new layer and name it, brush use all lower case letters.

3.) This is the step that got it all to work. Load the brushes the abr file that goes with that action.

4.) Use your brush and paint over the parts of the image you want the action applied to on the brush layer.

5.) Select the layer you named brush and play the action. Simple!

All works Great again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 18, 2020 0
New Here ,
Jun 13, 2020

Copy link to clipboard

Copied

Thank you so much, this worked perfec.tly

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 13, 2020 0
New Here ,
Mar 17, 2018

Copy link to clipboard

Copied

I do this, but I still run into layers that say they are not available.  I am pressing command and play for each layer.  Any advice?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 17, 2018 0
Most Valuable Participant ,
Mar 17, 2018

Copy link to clipboard

Copied

What command is not available? Commands have requirements  if a requirement for using the command is missing the comment is not available for use. For example if the background layer is the current target is the background layer and there is no selection command Cut, Copy, and Deselect would not be available.  If there were a selection those command would be available but command add layer mask using active selection would not be available because the background layer does not support transparency that layer transparency is locked.  You do not show a screen capture showing the error massage the Photoshop UI that shows the action step the document and the image window layers palette etc. We can not see what you see there is not way we can tell you why the command is not available please read these guidelines

Supply pertinent information for quicker answers

  • The more information you supply about your situation, the better equipped other community members will be to answer. Consider including the following in your question:
  • Adobe product and version number
  • Operating system and version number
  • The full text of any error message(s)
  • What you were doing when the problem occurred
  • Screenshots of the problem
  • Computer hardware, such as CPU; GPU; amount of RAM; etc.
JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 17, 2018 0
New Here ,
Jan 29, 2016

Copy link to clipboard

Copied

I had this exact same issue with an action I was using.  Look down the action list at the first "Select" command.  Make sure that your layer is named the same as what is in that command.  After that it should work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2016 5
Community Beginner ,
Jun 22, 2019

Copy link to clipboard

Copied

Done for me! Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2019 0
Most Valuable Participant ,
Jan 30, 2016

Copy link to clipboard

Copied

If you highlight the first step in the action hold down the Ctrl or CMD key. Then every time you click the Play button one action step will Play and the Highlight will move to the next step in the action.  As long as you keep the Ctrl of CMD key held down you will single step through the action with each click on the play button. You will see the results of each step.  You will see the state you document is in when select is not available.  It will be because of the document's current document state,

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2016 1
New Here ,
Nov 24, 2016

Copy link to clipboard

Copied

Amigo, aveces hacen falta los pinceles (brush), instala los pinceles y la acción se ejecuta.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 24, 2016 3
New Here ,
Apr 09, 2018

Copy link to clipboard

Copied

Eso fue exactamente lo que me paso! mil gracias por la ayuda!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 09, 2018 0