Highlighted

Using old PS in Mohave

New Here ,
May 08, 2020

Copy link to clipboard

Copied

I'm running Photoshop 12.0 x64 on MacOS Sierra, and I may need to update to Mohave because of other outdating programs. Will my version of PS work on Mohave? (Adobe tech support said "most likely", but that the community would know for sure.) Thanks!

Topics

Download and install, How to, Mac

Views

675

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Using old PS in Mohave

New Here ,
May 08, 2020

Copy link to clipboard

Copied

I'm running Photoshop 12.0 x64 on MacOS Sierra, and I may need to update to Mohave because of other outdating programs. Will my version of PS work on Mohave? (Adobe tech support said "most likely", but that the community would know for sure.) Thanks!

Topics

Download and install, How to, Mac

Views

676

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
gener7 LATEST
Adobe Community Professional ,
May 08, 2020

Copy link to clipboard

Copied

Yes. It's the last MacOS to do so. Do not upgrade to Catalina. If you upgrade in place you do not need to reinstall.

Also read this part: https://www.macworld.co.uk/how-to/mac-software/open-apps-mojave-photoshop-3684425/ to be sure CS5 will work in Mojave.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...