Vector Editing Still Horribly Bugged

Dec 09, 2020

Copy link to clipboard

Copied

So I thought my issues were resolved with the last post. They weren't. Point-wise selection and editing of vectors is still terribly bugged, annoying, and broken. Some tasks are even impossible.

 

  • If you select points and drag too quickly, the whole entire vector moves. There's some weird delay that wasn't there before in older version of PS. (No, it's not my PC - it happens an ALL my machines.)
  • If you select end points at one end of parallel lines, and then attempt to drag them horizontally or vertically tangentially to the parallel, the whole vector will drag instead of just the points. If you do an off angle (any angle NOT tangengial to the parallel), only the points move, as it SHOULD be. Trying to circumvent this with arrow key nudge doesn't work. (No, it's not my PC - it happens an ALL my machines.)
  • Vector line displays on the screen are utterly sluggish to display and respond. (No, it's not my PC - it happens an ALL my machines.)
  • Finally, no, it's not my PC - these happen an ALL my machines.

 

Please fix this, it's been almost months now.

TOPICS
Bug, Problem or error, Windows

Views

30

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Vector Editing Still Horribly Bugged

Dec 09, 2020

Copy link to clipboard

Copied

So I thought my issues were resolved with the last post. They weren't. Point-wise selection and editing of vectors is still terribly bugged, annoying, and broken. Some tasks are even impossible.

 

  • If you select points and drag too quickly, the whole entire vector moves. There's some weird delay that wasn't there before in older version of PS. (No, it's not my PC - it happens an ALL my machines.)
  • If you select end points at one end of parallel lines, and then attempt to drag them horizontally or vertically tangentially to the parallel, the whole vector will drag instead of just the points. If you do an off angle (any angle NOT tangengial to the parallel), only the points move, as it SHOULD be. Trying to circumvent this with arrow key nudge doesn't work. (No, it's not my PC - it happens an ALL my machines.)
  • Vector line displays on the screen are utterly sluggish to display and respond. (No, it's not my PC - it happens an ALL my machines.)
  • Finally, no, it's not my PC - these happen an ALL my machines.

 

Please fix this, it's been almost months now.

TOPICS
Bug, Problem or error, Windows

Views

31

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 09, 2020 0
Dec 09, 2020

Copy link to clipboard

Copied

What OS version and which Photoshop version and are your devices drivers up to date?  Are you sure you using the vector tools correctly? Have you tried resetting your Photoshop tools and preferences on all your PC machines. I do not see other users reporting vector editing has issues.

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 09, 2020 0
Dec 09, 2020

Copy link to clipboard

Copied

Could you post meaningdul screens recordings? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 09, 2020 0