Highlighted

Vector mask issue

Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

I do this process regularly, it has just stopped working properly.

I draw a path to create a vector mask and draw multiple 'sub-paths' inside the main shape to create knockouts (all part of the same path in the paths panel). With the Path Selection Tool, I marquee-select all the paths and Ctrl + click the Add Layer Mask button with Exclude Overlapping Shapes selected. Where I used to get the object perfectly cut out from the background, I now get the object perfectly missing with the background retained - as if it were an inverted pixel mask.

The other options, Combine... Subtract... Intersect... are not working normally either - although I'm not absolutely sure as I never use them, but none give me the desired result.

Worse... to get the proper names as I wrote this I did a really simple one, two concentric circles, and it worked as expected (I checked and it's still failing on complex ones).

The only recent setup changes are Topaz plugins updating - am I answering my own question with "uninstall the plugins"?

TOPICS
Bug, Problem or error

Views

33

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Vector mask issue

Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

I do this process regularly, it has just stopped working properly.

I draw a path to create a vector mask and draw multiple 'sub-paths' inside the main shape to create knockouts (all part of the same path in the paths panel). With the Path Selection Tool, I marquee-select all the paths and Ctrl + click the Add Layer Mask button with Exclude Overlapping Shapes selected. Where I used to get the object perfectly cut out from the background, I now get the object perfectly missing with the background retained - as if it were an inverted pixel mask.

The other options, Combine... Subtract... Intersect... are not working normally either - although I'm not absolutely sure as I never use them, but none give me the desired result.

Worse... to get the proper names as I wrote this I did a really simple one, two concentric circles, and it worked as expected (I checked and it's still failing on complex ones).

The only recent setup changes are Topaz plugins updating - am I answering my own question with "uninstall the plugins"?

TOPICS
Bug, Problem or error

Views

34

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 26, 2020 0
LEGEND ,
Aug 26, 2020

Copy link to clipboard

Copied

Please post meaningful screenshots (all the subPathItems selected, and Toolbar, Paths Panel, Options Bar, … visble) and post a jpg containg one of the affected Paths. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0
JJMack LATEST
Most Valuable Participant ,
Aug 26, 2020

Copy link to clipboard

Copied

What exactly is Ctrl+Click  on a  Add layer button  function?  I normally just click on the mask button in the tool option bar.  That add the current work Path as a vector layer mask all the closet paths have their correct mode as see in the Paths palette Work Path.    I never knew there was some Ctrl+Click operation for vector layer mask. ???

JJMack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2020 0