What Mac Software do I need to run Photoshop?

New Here ,
Dec 19, 2020

Copy link to clipboard

Copied

Hi, I have a MacBook Pro 2012 which is currently running Sierra. I need photoshop for uni, what is the lowest software that will run photoshop on my mac? It would be brill if anyone could help, thank you!

 

Adobe Community Professional
Correct answer by jane-e | Adobe Community Professional

Hi

Here are the system requirements:

https://helpx.adobe.com/photoshop/system-requirements.html

Operating system macOS Mojave (version 10.14) or later macOS Big Sur (version 11)
macOS Catalina (version 10.15)

Check all of the requirements, not just the OS. If you don't have PS now, you can download a free 7-day trial. Be sure to cancel within the seven days if it doesn't work.

~ Jane

TOPICS
Download and install, How to, Mac, Problem or error

Views

39

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

What Mac Software do I need to run Photoshop?

New Here ,
Dec 19, 2020

Copy link to clipboard

Copied

Hi, I have a MacBook Pro 2012 which is currently running Sierra. I need photoshop for uni, what is the lowest software that will run photoshop on my mac? It would be brill if anyone could help, thank you!

 

Adobe Community Professional
Correct answer by jane-e | Adobe Community Professional

Hi

Here are the system requirements:

https://helpx.adobe.com/photoshop/system-requirements.html

Operating system macOS Mojave (version 10.14) or later macOS Big Sur (version 11)
macOS Catalina (version 10.15)

Check all of the requirements, not just the OS. If you don't have PS now, you can download a free 7-day trial. Be sure to cancel within the seven days if it doesn't work.

~ Jane

TOPICS
Download and install, How to, Mac, Problem or error

Views

40

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 19, 2020 0
Adobe Community Professional ,
Dec 19, 2020

Copy link to clipboard

Copied

Hi

Here are the system requirements:

https://helpx.adobe.com/photoshop/system-requirements.html

Operating system macOS Mojave (version 10.14) or later macOS Big Sur (version 11)
macOS Catalina (version 10.15)

Check all of the requirements, not just the OS. If you don't have PS now, you can download a free 7-day trial. Be sure to cancel within the seven days if it doesn't work.

~ Jane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2020 0
New Here ,
Dec 19, 2020

Copy link to clipboard

Copied

Thank you very much Jane!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2020 0
jane-e LATEST
Adobe Community Professional ,
Dec 19, 2020

Copy link to clipboard

Copied

You're welcome, @Freya5FB4 .

~ Jane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2020 0