Zoom tool acting crazy (Photoshop CC 2014)

Explorer ,
Jul 12, 2014 Jul 12, 2014

Copy link to clipboard

Copied

Hello, all. I'm starting to go crazy here. Whenever I use the Zoom tool in Photoshop CC 2014, it zooms in continuously and doesn't stop zooming until it reaches an absurdly zoomed-in level (like 3200%). And when I try to zoom out, the reverse happens, and zooms out all the way to a tiny size. I the past I was able to zoom in standard increments of 25%, 33.3%, 50%, 66.7%, etc. but now I can't hit any of those numbers.

I made this video of my screen to show you exactly what's happening: Photoshop zoom error on Vimeo

One thing to note is that the zoom tool works properly when I use my keyboard shortcuts (Command and + or - keys) but when I use the mouse or laptop trackpad it goes haywire.

Thanks for any help!

Views

13.1K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 12, 2014 Jul 12, 2014

Copy link to clipboard

Copied

I should probably add a description of my setup:

MacBook Pro Retina (Rev A)

2.7 GHz Core i7

750GB HDD

16GB RAM

Mac OS X 10.9.4

Photoshop CC 2014

Apple Thunderbolt Display

The zoom problem started when I upgraded from OS X 10.9.2 to 10.9.3 when using Photoshop CC. Then I upgraded to Photoshop CC 2014, but the issue remained. After that, I upgraded to OS X 10.9.4 and re-installed Photoshop CC 2014. The problem doesn't go away. Any help would be greatly appreciated.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 15, 2014 Jul 15, 2014

Copy link to clipboard

Copied

Anyone? Bueller?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2014 Jul 15, 2014

Copy link to clipboard

Copied

So if you click on the photo with the zoom tool and release the mouse button right away, it just keeps zooming or does it stop?

It's possible that before the updates, Use Graphics Processor was turned off in photoshop>preferences>performance

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

Exactly. I click on the photo with the zoom tool (either with the left mouse button or with the trackpad) and immediately release the button, but the image keeps zooming in all the way, long after I stopped pressing the button. However, when I use the keyboard shortcuts for zooming in & out (Command key and + or - keys) the zoom tool works perfectly.

I tried turning "Use Graphics Processor" off and on again, but no change. It's still messed up.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

Try resetting the Zoom Tool, Control-click on the Zoom icon and select Reset Tool.

Screen Shot 2014-07-16 at 12.27.23 AM.png

Failing that, you could try resetting your preferences. (Mac: Command, Option, Shift) while starting up Photoshop. A dialog box will appear asking if you wish to delete the preferences/settings file.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

I tried resetting the Zoom tool. No dice.

I also reset Photoshop preferences (Command + Option + Shift while opening Photoshop) and it still doesn't work right.

One thing I've noticed is that while the image is zooming, I'm unable to click on anything else in the computer until it's done zooming. For example, I click on Zoom, then try to click on a different app, but it won't open. I try to click on a different app that's already open, and it won't switch to it until the zoom is done.

I'm at a complete loss here. It seems to me that it's a problem with the computer, not with Photoshop, since it all started when I upgraded to OS X 10.9.3. I would have thought that installing a new version of Photoshop in addition to upgrading to 10.9.4 would fix it, but no.

If anyone has any ideas, I'm all ears. Thanks for your help so far, R_Kelly and gener7.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

You might try turning off use Gestures in the photoshop>preferences>interface

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 16, 2014 Jul 16, 2014

Copy link to clipboard

Copied

Hi Jaime,

Sorry to hear those suggestions didn't pan out. I use a mid 2009 Macbook, 10.9.4, and CS6, CC, CC 2014, and I only use my trackpad. I have never experienced anything as you have.

However, I did google around to see if I could get some clues. Animated zoom was designed to continuously zoom in as the mouse button was held down. Something is telling Photoshop that a left-click is the same as holding down the button. So here's my take:

Go into Photoshop Preferences > General, uncheck Animated Zoom, restart PS for good measure and see if it goes away.

Also a thought, do you have any third party mouse utilities like "BetterTouchTool"?

Gene

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

Thank you!!! This has saved me from a mental breakdown!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 08, 2014 Dec 08, 2014

Copy link to clipboard

Copied

Adobe Photoshop CC 2014.2.1 Release

Selecting An Area With The Zoom Tool

This feature is known as Scrubby Zoom. By default, the option is enabled, but you can turn it off by unchecking it in the Options Bar (when the Zoom Tool is selected):

Unchecking the Scrubby Zoom option for the Zoom Tool. Image © 2014 Steve Patterson, Photoshop Essentials.com

Unchecking the Scrubby Zoom option.

With Scrubby Zoom disabled, the Zoom Tool behaves much like Photoshop’s Rectangular Marquee Tool. Simply click and drag out a selection box around the area you want to zoom in on.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 18, 2019 Sep 18, 2019

Copy link to clipboard

Copied

Worst default setting ever.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 12, 2014 Dec 12, 2014

Copy link to clipboard

Copied

Hi,

I just wanted to say I have the same problem, but I randomly found out that if you use both fingers on the trackpad it will work fine. Until someone finds a solution I've been using this trick.

Thanks

Screen Shot 2014-12-12 at 5.26.28 PM.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 13, 2015 May 13, 2015

Copy link to clipboard

Copied

I had the same issue, but turning off "Better touch tool" app helped! (if you have that )

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 28, 2016 Oct 28, 2016

Copy link to clipboard

Copied

"I had the same issue, but turning off "Better touch tool" app helped! (if you have that ) — topip74077694

THANK You for posting this. I was losing my mind.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 28, 2016 Oct 28, 2016

Copy link to clipboard

Copied

Same as poster above.  I turned off my "Better Touch Tool" plug-in and the problem went away.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines