Elements 2021 Photo Editor is fine....but Video Editor will not load...any ideas?

New Here ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

Elements 2021 Photo Editor is fine....but Video Editor will not load...any ideas?

TOPICS
Error or problem , Import , Tips and tricks

Views

95

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

You need to provide details for anyone to help
Mac or Windows and exact version of the operating system

CPU brand and model and clock speed
Amount of computer memory (RAM)
Video adapter brand and model and driver version and amount of video ram
Number and size and type of hard drives

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

Thanks...I'll gather that info and respond 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

Windows 10

AMD Ryzen 5 1600 Six-Core Processor   3.20 GH

64-bit operating system, x64-based processor
8GB Ram
NVIDIA GeForce GTX 550 Ti

Driver version  - 23.21.13.9135

2TB SSD hard drive

 

I have recently updated from Elements Photo and Video 15.  Photo Editor 21 works fine. Video Editor wont load...it tries...and fails.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

>NVIDIA GeForce GTX 550 Ti

 

Do not count on Windows to be fully up to date when it comes to device drivers
Go to the vendor site to be sure you have an updated driver for your graphic adapter
nVidia Driver Downloads http://www.nvidia.com/Download/index.aspx?lang=en-us
-use the STUDIO driver, not the GAMING driver

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

I'll get my techie to do all that...he's my son and knows his stuff. 🙂 Thanks, I'll let you know how I (he) gets on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

LATEST

In another topic Ann Benns offered a link to some information that your son the techie might be able to use.

https://helpx.adobe.com/nz/premiere-elements/kb/playermediacore-loading-issue.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

Did you run the program as an administrator?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

I have no idea what you mean 🙂    I'm just a simple end-user 🙂  It's very strabnge that photoeditor is fimne but video editor won't load. I've re-installed Elements 2021 and still get the same result...photo good...video no good.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines