• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Incompatible display driver for Adobe Premiere Elements 10

New Here ,
Jan 13, 2024 Jan 13, 2024

Copy link to clipboard

Copied

Hi all, hoping I can get some help/answers...

I have been using my OLD Adobe Premiere Elements 10 on my 2+ year old Dell (running Windows 10) all this time with very little issue. (Yes, the program is ancient, but it's WHAT I HAVE. And for the editing I do, it has worked for me. No judging please! :P)  Up until what I can only assume was around October, my computer must have run a particular update that SCREWED something up with the display driver. And since I will sometimes go weeks or MONTHS between using my PE program, I did not know this had happened at the time, so now it is too late to do any restoring.

When I start the program, it gives me a pop-up saying:
"We have detected an incompatible display driver. To get a better and faster playback performance, please update your display driver. 

Display driver details :Intel - Intel(R) UHD Graphics 630 3.0.0
Build 27.20.100.9664" 
...I click OK and my program runs normal for the MOST part, except when I double click a video from my project tab to watch a preview, you know, so I can scroll the clip, or set in/out points before adding it to the timeline, it is just GRAY. The audio is there, but no video. Now, once the clip has been added to the timeline, it seems to play normal with no issue in the playback window. It's only not there in the preview window. I RELY on the preview feature a LOT for what I do and I am extremely frustrated that something that was working FINE before got changed, and I am so computer illiterate that I don't know how to fix this, or even if I CAN fix this.


Installing a newer version of Premiere Elements is out of the question right now as I have been working on an ongoing movie project through my Elements 10 for nearly 4 years. As far as I know, my project files from my old program would NOT transfer into a newer version. I could be wrong, but I'm pretty sure I remember experimenting with a family member's newer program to bring in my old version files to it and it did not work. I am also not interested at this time to even attempt to relearn a newer version. Down the road maybe, but  RIGHT NOW, I just want my rinky dink Elements 10 to work like it was, long enough to at least finish this huge movie project.

Like I said, I am not the most computer savvy person (obviously), so if anyone has any remedies or suggestions, I would VERY VERY much appreciate it. (And please word things in an extremely simplified language that I can understand..lol :/)
I don't know if this helps with anything, but my processor is an:
Intel(R) Core(TM) i7-10700 CPU @ 2.90GHz 2.90 GHz

And under my Device Manager, under Display Adapters it says:

Intel(R) UHD Graphics 630

NVIDIA GeForce GTX 1660 Ti

 

SEND HELP!  Thanks in advance!

TOPICS
Error or problem , Performance , User interface or workspaces

Views

193

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Jan 17, 2024 Jan 17, 2024

I had this kind of issue when working with versions 9 and 11.

In my case, the solution was to delete the file BadDrivers.txt in Program Data > Adobe> Premiere elements> 10.0

You can try this, there is no risk because the file is re-created when PREL restarts.

 I found the solution on this forum, 12 years ago ! 

Best regards from France

Votes

Translate

Translate
Community Expert ,
Jan 14, 2024 Jan 14, 2024

Copy link to clipboard

Copied

You will have to go to the intel website, download the latest driver and install manually.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 14, 2024 Jan 14, 2024

Copy link to clipboard

Copied

Also check the Dell site for drivers.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 14, 2024 Jan 14, 2024

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 14, 2024 Jan 14, 2024

Copy link to clipboard

Copied

You wrote asking for suggestions.   

 

First, don't open your projects in a newer version.  It has been verified that newer versions are not backward compatable.  

 

Second, consider a backup plan.  Output a best quality version of your project.  If necessary, that can be used as  source media for a project in any other editing software.   Then, if the entire PrE version 10 fails, you won't have lost everything.   As it is, you are totally reliant on software that has become too old.   

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2024 Jan 17, 2024

Copy link to clipboard

Copied

I had this kind of issue when working with versions 9 and 11.

In my case, the solution was to delete the file BadDrivers.txt in Program Data > Adobe> Premiere elements> 10.0

You can try this, there is no risk because the file is re-created when PREL restarts.

 I found the solution on this forum, 12 years ago ! 

Best regards from France

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 17, 2024 Jan 17, 2024

Copy link to clipboard

Copied

LATEST

Oh my gosh MERCI!!! This WORKED! You are a lifesaver! 😄 SIMPLE AND EASY fix. *happy dance* I really was not wanting to mess with downloading new drivers for fear it might just screw things up even MORE, so this was beautiful. Thank you again, very appreciated.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines