Jerky Video in timeline -Premiere Elements 2022 - File plays fine in all other programs

New Here ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

Wow... what a dissapointment Premiere Elements 2022 has turned out to be.

 

I have a new PC designed for video and photo editing/  24 gig RAM,  i7 CPU (i7-10750H) , SSD had drive running Windows 10, Nvidia GeForce GTX1650 Ti graphics card.

 

I have old version of Premiere CS5.5, vegas video and variopus other editing software.

 

Though I'd try Premiere Elements for easy edits.... What a piece of crap!   Video playback on timeline is SOOOO jerky, I'm not able to edit it properly.  Same files play back flawlesly in Premietre CS 5.5, Vegas video and Windows media player.  

 

I've tried numerous project settings, upgraded to the latest Premiere 2022, upgraded my Nvidea graphics card to latest edition.... Video playback is still jerky as hell. 

 

What gives Adobe?   I thought you have good products.

 

This ones a fail!  Would like to get my money back

 

Barry 

TOPICS
Performance

Views

57

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

I have a four year old laptop with lower specs than yours.  I have no trouble with "smooth" timeline performance.  It is never jerky, even with 4K video.   When this comes up on this forum, it usually gets fixed with some settings adjustments.   Oddly, one of the settings has to do with audio.  If it is wrong, the computer somehow gets overloaded and slows down the preview generations.  There may be exceptions, so by all means, use the 30 day satisfaction guarantee to get your money back.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

LATEST

Make sure Default Input in the Audio Hardware in the Preferences is set to No Input.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines