Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Premier Elements Activation issue

New Here ,
Jun 30, 2021 Jun 30, 2021

Copy link to clipboard

Copied

Hello.

 

I have a new laptop and want to install my Premier Elements 14 on it. I deactivated it from my old laptop with no issue. Now when I put in the (confirmed official) license, it says it cannot validate the license and to get in touch with customer service. Which I did on Chat. They asked for my number and sent me this message;

 

Support is no longer available for your product version. Phone and chat support is not available for free or discontinued software or services. You are welcome to visit our Community Support Forum: https://community.adobe.com/ where you can post questions, and potentially find answers for your product version. The forums are updated by other Adobe product users, worth noting that the community experts will not be able to assist with : registration, activation, download, and/or installation issues

I don't know what to do next. Any ideas?

 

Thanks!

D

TOPICS
Error or problem

Views

115

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jun 30, 2021 Jun 30, 2021
When you can't deactivate a serial number to activate in a new computer BE SURE TO ONLY ASK FOR ACTIVATION SUPPORT TO ADJUST YOUR ACTIVATION COUNT You may need to PERSIST or TRY AGAIN to find a support agent with more experience Sorry, nobody here can help with an account or payment problem This is a public forum, you need the link to Adobe support, not other users Be sure to remain signed in with your Adobe ID before accessing the link Do be aware that Adobe's staffing is impacted by the virus,...

Likes

Translate

Translate
Adobe Community Professional ,
Jun 30, 2021 Jun 30, 2021

Copy link to clipboard

Copied

When you can't deactivate a serial number to activate in a new computer
BE SURE TO ONLY ASK FOR ACTIVATION SUPPORT TO ADJUST YOUR ACTIVATION COUNT
You may need to PERSIST or TRY AGAIN to find a support agent with more experience

Sorry, nobody here can help with an account or payment problem
This is a public forum, you need the link to Adobe support, not other users
Be sure to remain signed in with your Adobe ID before accessing the link
Do be aware that Adobe's staffing is impacted by the virus, so wait times are long
-make sure that your browser does NOT block ads, scripts, or pop-ups
-you must also allow 'cookies' in your web browser for the link to work
This link will go directly to the chat option
Type "Agent" in the chat box to bypass the chatbot and be connected to a person
-Meaning type in the word Agent without the quote " " marks
https://helpx.adobe.com/contact.html?rghtup=autoOpen
- or https://helpx.adobe.com/contact/phone.html
.
Also: beware of answering anyone who sends you a private message
-click for more information about scammers https://tinyurl.com/10791730

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

Thanks. That worked! I really appreciate it. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 11, 2021 Sep 11, 2021

Copy link to clipboard

Copied

I am having the same issue with registration of Premiere Elements, version 13 on a High Sierra iMac. Can't find how to find the chat box or support.

 

Even with unrestricted Safari blockers and open privacy settings... the chat box does not display in the new webpage as indicated above.

 

I am the original purchaser and sole user, always have been. Bought the product retail in the U.S. and I am looking at the original packaging and discs as I type. This was not ebay, gray market, downloaded, 99 Cents store, etc. It's legit. And, there has never been a problem reinstalling PREL in the past.

 

I am also a longtime CC subscriber of PS and AI.

 

The serial number for PREL is indicated on my Adobe account, but after a fresh install of my OS and apps, and then PREL, I continue to get an error message that "can't log in to the internet to verify the serial" something like that.

 

Well... my internet is working perfectly fine, and the email for my account is 100% correct. I re-entered my account email address and password. Still no luck.

 

I can't use Adobe legacy software that I own, and can't find any text/chat/email/telephone contact to resolve a simple issue? Are Adobe products so error-free that a support ecosystem is not longer necessary?

 

I just want to finish my video products.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 11, 2021 Sep 11, 2021

Copy link to clipboard

Copied

See if this helps... TLS 1.2 is required https://helpx.adobe.com/x-productkb/multi/eol-tls-support.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 11, 2021 Sep 11, 2021

Copy link to clipboard

Copied

Not sure how it helps. My PS and AI 2020 work fine under High Sierra, I can login into my Adobe account with my computer and Safari 13.2. 

 

Is my legacy Premiere Elements 13 using some old technology to activate the software?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 11, 2021 Sep 11, 2021

Copy link to clipboard

Copied

maybe chatbots don't work on Saturdays? I did not see the chat icon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 12, 2021 Sep 12, 2021

Copy link to clipboard

Copied

LATEST

FYI... the chatbox icon does not appear unless all cookies are accepted. 

 

Adobe spent 2 hours mirroring my system, exploring and resetting things, network stuff, deleting, being put on hold to speak with "supers", restarting.

 

No matter what was done, the activation problem never went away. I bought the CD package years ago, new from a legit retailer, I have installed this software on my computer, always running High Sierra, never had a problem until now. Apart from a clean install of OSX High Sierra recently, my configuration hasn't changed. Well... I bought a new mouse.

 

And, I am a CC user and never had issues like this.

 

In the end, the problem is not solvable. The Adobe agent gave me a weblink to upgrade to ver 15 along with the serials. He made a heroic effort, commendable, and I'm surprised his "supers" allowed him to spend so much time on a marginal product in the Adobe lineup. Great job Adobe, I didn't expect that kind of effort.

 

Vers 15 works perfectly... as vers 13 did previously.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines