• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Video preview window is black

New Here ,
Mar 12, 2018 Mar 12, 2018

Copy link to clipboard

Copied

For Adobe Premiere Elements 12 on Windows 7 (32 bit) I tried to import a m4v file. Once it imported it, the video preview window is black. Audio works fine.

Why is the preview window black?

Views

523

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Mar 14, 2018 Mar 14, 2018

Might work if you change the extension to mp4 or mts if that does not work,

run the file through HandBrake and convert to mp4.

See how that goes.

Votes

Translate

Translate
Community Expert ,
Mar 13, 2018 Mar 13, 2018

Copy link to clipboard

Copied

It may be explained by what Wikipedia says: 

"The M4V file format is a video container format developed by Apple and is very similar to the MP4 format. The primary difference is that M4V files may optionally be protected by DRM copy protection.

Apple uses M4V to encode video files in its iTunes Store. Unauthorized reproduction of M4V files may be prevented using Apple's FairPlay copy protection."

It may also be that if you install Quicktime on your computer, Premiere Elements will "borrow" the necessary codecs. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 13, 2018 Mar 13, 2018

Copy link to clipboard

Copied

Thanks for the suggestion. However, I already have QuickTime installed (it's no longer supported by Apple so the latest version is at least 2 years old). I confirmed that I can open the m4v file with QuickTime just fine.

I know that the m4v is not DRM protected, so that's not the issue.

I'm running Windows as a VM in Virtualbox 5.2. For my VM's configuration, if I have "Enable 3D Acceleration" and "Enable 2D Acceleration" selected, the preview window is black. When only "Enable 2D Acceleration" is selected or if neither of the options are selected, then the preview window is not black and actually shows the correct video. However, the audio and video are badly out of sync when I play/preview the video in Expert view. So, I guess I know how to get past the black preview window issue, but I don't know how to get past the sync issue.

Any suggestions, given my scenario?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 14, 2018 Mar 14, 2018

Copy link to clipboard

Copied

Might work if you change the extension to mp4 or mts if that does not work,

run the file through HandBrake and convert to mp4.

See how that goes.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 14, 2018 Mar 14, 2018

Copy link to clipboard

Copied

Thanks for the tip about QT. I uninstalled and reinstalled it with just the codecs.

I ran the video files through handbrake and made sure to output them with a constant frame rate. PE12 has no problem handling the files now...no sync issues.

So, it appears that PE12+ just doesn't handle variable frame rate source files (well or at all).

Others seem to agree

Premiere Elements needs to handle variable frame rate files. | Photoshop Family Customer Community

Is this an official confirmed bug?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 15, 2018 Mar 15, 2018

Copy link to clipboard

Copied

So, it appears that PE12+ just doesn't handle variable frame rate source files (well or at all).

Non of the Elements versions do.

Hence the suggestion of Handbrake.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 14, 2018 Mar 14, 2018

Copy link to clipboard

Copied

You dont need the QT player just the codec.

install like this:

QT+essentials.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 15, 2023 Sep 15, 2023

Copy link to clipboard

Copied

None of these answers apply here.  It is video that had worked the day before without going black.  Not all the video went black just the end of it as the frames before it were edited.  It has an mp4 extesnsion.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 15, 2023 Sep 15, 2023

Copy link to clipboard

Copied

LATEST

You added to a 5 year old discusion about Premiere Elements 12 on Windows 7 (32 bit)

 

You need to provide your computer and software details

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines