(Win11) Elements Editor 2022 fails to start - initialisation stops at 'ImporterQuicktime.prm'

New Here ,
Dec 25, 2021 Dec 25, 2021

Copy link to clipboard

Copied

I have just purchased the combined Photoshop/Premier Elements package. My HP All-in-One is running the latest version of Windows 11. It was a clean install of both software parts. The Photoshop program functions correctly.

Launching the Premier Editor brings up the usual loading graphic, whereupon it cycles through loading the various core executablesam runing but completely disappears/terminates at loading 'Importerquicktime.prm', returning to the main selection screen. Repeated attempts produce the same result, as does removing/reinstalling Premier Elements.

Having just paid a considerable amount, I am upset that the Premier Elements software does not function!

TOPICS
Freeze or hang

Views

83

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 25, 2021 Dec 25, 2021

Copy link to clipboard

Copied

Contact support over chat.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 25, 2021 Dec 25, 2021

Copy link to clipboard

Copied

On Christmas Day? I don't think so. Maybe towards the New Year...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 25, 2021 Dec 25, 2021

Copy link to clipboard

Copied

Go to the top of the page where is says SEARCH THIS COMMUNITY in a box and enter Importerquicktime to be able to read previous discussions of that problem

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 25, 2021 Dec 25, 2021

Copy link to clipboard

Copied

I have used the search. None reflect Premier Elements or Windows 11. None solve the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 25, 2021 Dec 25, 2021

Copy link to clipboard

Copied

LATEST

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 25, 2021 Dec 25, 2021

Copy link to clipboard

Copied

Solved. Problem seems to be with the generic Adobe Launch Page. Creating a direct 'Run as admin' link to the .exe file (within the Premier folder) saw it operate correctly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines