Highlighted

Clicking "Edit Video" does nothing, Premiere Elements never loads

New Here ,
Sep 14, 2020

Copy link to clipboard

Copied

This is on an Apple iMac running 10.13.6

 

I just did a trial install for Premiere Elements.   It seemed to work and I ended up with a new app in the Applications folder.    I can bring up the main screen that has thee options for organizers, photoshop elements, or Premiere Elements.  Clicking "organizer" works.   Clicking "edit video" does nothing.  A message pops up saying it is loading the video edit workspace but it never does load.

 

Also in the Application folder is the editor app "Adobe Premiere Elements.app" (a 2.28GB app bundle) but clicking this does nothing.  Looks like it tries to load then fails silently.

TOPICS
Crash, Error or problem, Freeze or hang

Views

35

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Clicking "Edit Video" does nothing, Premiere Elements never loads

New Here ,
Sep 14, 2020

Copy link to clipboard

Copied

This is on an Apple iMac running 10.13.6

 

I just did a trial install for Premiere Elements.   It seemed to work and I ended up with a new app in the Applications folder.    I can bring up the main screen that has thee options for organizers, photoshop elements, or Premiere Elements.  Clicking "organizer" works.   Clicking "edit video" does nothing.  A message pops up saying it is loading the video edit workspace but it never does load.

 

Also in the Application folder is the editor app "Adobe Premiere Elements.app" (a 2.28GB app bundle) but clicking this does nothing.  Looks like it tries to load then fails silently.

TOPICS
Crash, Error or problem, Freeze or hang

Views

36

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 14, 2020 0
Adobe Employee ,
Sep 25, 2020

Copy link to clipboard

Copied

Hi there,

I understand you are unable to launch Premiere Elements on macOS. Though the latest version should work on macOS 10.13, yet it is recommended to update your OS to avoid any malfunctions or performance glitches. Have you considered updating your OS to the latest version? 

Let us know. We're here to help.

Thanks,

Shivangi

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2020 0
New Here ,
Sep 25, 2020

Copy link to clipboard

Copied

This Mac is running the last version of MacOSthat can run on the hardware.
Apples' "automatic update" is enabled. In fact just today Apple released a
new version of 10.13 and I just rebooted after installing it. STILL the
same problem Adobe Premiere Elements silently crashes.

I think that possibly the statement that Adobe Premiere Elements runs on
Macos 10.13 is not correct.

Updating the hardware will make sense AFTER the transition to ARM-based
Macs is over and Adobe (and Microsoft and others) have products that run on
the new ARM based macs.

My real question is how to debug this and get Elements to run on a Mid 2011
iMac with 10.13.

One option I will try is downgrading to an earlier version of Adobe
Premiere Elements. Perhaps from 2019 or 2016.

--

Chris Albertson
Redondo Beach, California

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2020 0