Highlighted

GPU acceleration with Premiere Elements 2019 ?

New Here ,
Feb 05, 2019

Copy link to clipboard

Copied

I'm currently trying Premiere Elements 2019. Even for playback of imported videos, CPU is 100%. And it is no longer smooth as soon as filters are added. By contrast, GPU usage remain Under 5%.

I'm using other Adobe products (photography) where my GC is recognised and used without an issue.

Does Premiere Elements 2019 benefits from a GPU, at least during playback ?

---

Laptop with recent i7-8565U CPU, and a MX150 GPU (not great but fully capable of playing 4K perfectly smoothly)

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

GPU acceleration with Premiere Elements 2019 ?

New Here ,
Feb 05, 2019

Copy link to clipboard

Copied

I'm currently trying Premiere Elements 2019. Even for playback of imported videos, CPU is 100%. And it is no longer smooth as soon as filters are added. By contrast, GPU usage remain Under 5%.

I'm using other Adobe products (photography) where my GC is recognised and used without an issue.

Does Premiere Elements 2019 benefits from a GPU, at least during playback ?

---

Laptop with recent i7-8565U CPU, and a MX150 GPU (not great but fully capable of playing 4K perfectly smoothly)

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 05, 2019 0
Adobe Community Professional ,
Feb 05, 2019

Copy link to clipboard

Copied

No.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 05, 2019 1
Adobe Community Professional ,
Feb 05, 2019

Copy link to clipboard

Copied

tokumeino  wrote

...... CPU is 100%. And it is no longer smooth as soon as filters are added.

Are you initiating preview rendering after the filters are added?  Also, double check your Audio Hardware preferences.  The Default Input should be "None".  Setting to none may relieve some of the CPU workload as it plays previews.  

There are also settings on the General Preferences page that may make a difference.  The Hardware Acceleration setting may have a a backwards effect.  Turning it off has been know to improve playback.   Try the different settings under Timeline Render Quality too.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 05, 2019 0