New Premiere Elements 2021 not starting up

New Here ,
Nov 01, 2020 Nov 01, 2020

Copy link to clipboard

Copied

I downloaded Elements 2021 and Premiere Elements 2021. Elements start up great. Premiere went thru all the start up initaillizing actions but failed to open the program. No error codes. It just did not open. I even tried uninstall download and re=install. Same problem. Help please.

 

Paul-in-CRESSY_0-1604249474883.png

 

TOPICS
Error or problem

Views

684

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 01, 2020 Nov 01, 2020

Copy link to clipboard

Copied

It looks like the Elements Hub did install and open.

 

What operating system are you using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 01, 2020 Nov 01, 2020

Copy link to clipboard

Copied

I am using the latest (update) Windows 10.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 01, 2020 Nov 01, 2020

Copy link to clipboard

Copied

Have you manually ensured you have the latest drivers for your graphics card from the nVidia or AMD site?

 

Which graphics card do you have?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2020 Nov 09, 2020

Copy link to clipboard

Copied

Yes nVidia says I have the latest driver.

Paul-in-CRESSY_0-1604916556419.png

As I said before I have Premiere Elements 14 which works fine. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 01, 2021 Jan 01, 2021

Copy link to clipboard

Copied

Same problem.

 

Yesterday it worked.  I created a video and saved it, but today nothing.  No matter what I do

 

Message says - "Loading Adobe Premier Elements Editor Workspace" ---  And then is just just not do it.  Photo editor works - but no video editor.  Nothing changed in computer since yesterday. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 01, 2021 Jan 01, 2021

Copy link to clipboard

Copied

I tried the 2020 version - no problem -- the 2021 version - NOT working.  I am certain this is an Adobe issue, not my computer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 01, 2021 Jan 01, 2021

Copy link to clipboard

Copied

My Premiere Elements 2021 still does not come up. It tries loading then
just disappears with no error notification. The Organizer and Photo editor
2021 work fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2021 Jan 02, 2021

Copy link to clipboard

Copied

I have the same problem.  Any resolution here?  I was able to work on a project immediately after installing Premiere Elements 2021 but I try to start the program now and nothing.  Adobe, HELP.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2021 Jan 02, 2021

Copy link to clipboard

Copied

No fix found yet. I just tried starting up Premiere 2021 again. IT goes
through all the preload startup setup then just disappears with no error
warning.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 02, 2021 Jan 02, 2021

Copy link to clipboard

Copied

Assuming you're on Windows 10, right-click on the Task Bar and select Task Manager. Under the Processes tab, look through the Background Processes. for Adobe Premiere Elements. If it is running, end it. Then try to re-launch the program.

 

Also DO make sure your video card's latest driver is installed. That means going to the nVidia or AMD site, not trusting Windows to update it for you. nVidia and AMD release drivers every couple of weeks while your Windows driver could be more than a month old.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 16, 2021 Jul 16, 2021

Copy link to clipboard

Copied

I am having the exact same issue. Any resolutions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 16, 2021 Jul 16, 2021

Copy link to clipboard

Copied

20210716_203502.jpg

20210716_203241.jpg

  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2021 Jul 23, 2021

Copy link to clipboard

Copied

Was there a fix? It seems like this is a recurring problem so why hasn't adobe addressed this obvious problem?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

As we often say, Windows does not necessarily provide the latest drivers.

 

For nVidia and GeForce GPUs I recommend downloading this software from their site.

https://www.nvidia.com/en-us/geforce/drivers/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

LATEST

I ended up doing a live chat and having the Adobe two share my computer. In
the end we got it working again. Seemed like it was maybe tied to me having
my vpn on when i did the initial install.

Stephan Guénette
REMOVED

[personal information removed for your protection]
[This is a public forum, not Adobe support, please do not post personal information]

Also: beware of answering anyone who sends you a private message
-click for more information about scammers https://tinyurl.com/10791730

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines