performance problems with Premiere Elements 2021

New Here ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Hi, I'm writing from Italy, I'm new in the video editing software works and I was looking for an easy software to create footages and soft editings.

I'm using Premiere Elements 2021's free trial period; my CPU is i9-9900K and my GPU is RTX2070, I'm usign 32GB of RAM.

My problem looks like being related to the lack of RTX 2070 GPU support from Adobe: the video preview is very slow, sluggish, everything is slow and lagging compared to other softwares (even the micro preview of some effects to add to the video), when I simply delete some characters from the text I'm experiencing a lag of more than one second.

Is everyone else having the same problems?

Is there a way to fix it?

Thanks.

TOPICS
Performance

Views

111

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

What device recorded the video you are editing and what is this video's resolution and format?

 

Poor performance usually means a mismatch in your video and project settings. You certainly have enough power to edit video? If you look under the Edit menu, what is listed on the General page under Project Settings?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2021 Jan 05, 2021

Copy link to clipboard

Copied

My videos are taken with a Sony A7RIII internally, so 3840x2160 @25fps, 4:2:0 8 bit and a 100Mbps bitrate.

The strange thing is that the exporting time is correct (CPU running at 100% with processing time similar to other softwares) and the final video quality is equal to the input video quality

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Steve is right.  But also check Edit > Settings > Audio Hardware > Default Input to "No Input".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 05, 2021 Jan 05, 2021

Copy link to clipboard

Copied

Dario,

I routinely edit 3840x2160 @30fps from a Panasonic.  My computer has an i7 CPU.  My GPU is not supported.  I've used the last few versions of Premiere Elements for 4K editing.  I don't have laggy previews.    So, again the suggestion is to look at settings.    How are you setting up the project?  What are the project settings?  What are the settings on the Edit > Preferences > General page? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 06, 2021 Jan 06, 2021

Copy link to clipboard

Copied

LATEST

settings.jpg

 

I enclose the screenshot of the general settings, they should be as they are by default.

The second screenshot is about the project settings after I've imported my video in the timeline, and everything looks correct.

settings2.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines