Premier Elements 2021 choppy

New Here ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

Elements is choppy playback, slow to respond and will not save..... went through all old posts and made adjustments to settings with no avail. Attached is my system which seems to meet the requirements. Any help would be great as it seems Adobe customer support is almost impossible to find help or reach out. 

TOPICS
Crash, Freeze or hang, Performance

Views

112

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

Please insert your picture so people don't have to download unknown files

 

ReplyPic.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 08, 2020 Dec 08, 2020

Copy link to clipboard

Copied

Your specs show Windows 10 Pro on an i7-7500U processor with 16 gb of RAM. I don't see any information on your graphics card or how much free space is on your hard drive.

 

According to this benchmark chart, your processor rates a 3,690. In my books I recommend a benchmark rating of at least 6,500 with 10,000 being better. So you're a bit underpowered. More so if this is a laptop. However, there are other factors.

 

What model of camcorder is your video coming from and what is the video's format and resolution? 4K video is way out of your range and you may also struggle with HD video if your project settings are mismatched with your video specs.

 

What happens if you open a new project and just add a doze or so photos to the timeline? Does the program struggle with such a simple timeline or only with your video?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 08, 2020 Dec 08, 2020

Copy link to clipboard

Copied

LATEST

By my estimate, two common "choppy playback" issues with i7 equipped computers are an Audio Hardware setting and mismatched Project Settings.  

 

Check the Edit > Preferences > Audio Hardware for Default Input set to None.   

 

Then, as Steve suggests, can you post the Project Settings along with a description of the source video media?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines