Highlighted

Premiere Elements 10 Clip Monitor not working

New Here ,
Feb 16, 2020

Copy link to clipboard

Copied

Since buying a new PC with Windows 10 and installing my existing version of Premiere Elements 10, the clip monitor will not display the video in the Timeline. Do I need Adobe Flash Player and Adobe Air installed on my PC?

I also have a Laptop with the same version of Premiere Elements 10 and that works fine. I noticed that the laptop has Flash Player and AIR installed on it.

Or am I barking up the wrong tree?

 

Any help would be much appreciated.

TOPICS
Error or problem

Views

52

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Elements 10 Clip Monitor not working

New Here ,
Feb 16, 2020

Copy link to clipboard

Copied

Since buying a new PC with Windows 10 and installing my existing version of Premiere Elements 10, the clip monitor will not display the video in the Timeline. Do I need Adobe Flash Player and Adobe Air installed on my PC?

I also have a Laptop with the same version of Premiere Elements 10 and that works fine. I noticed that the laptop has Flash Player and AIR installed on it.

Or am I barking up the wrong tree?

 

Any help would be much appreciated.

TOPICS
Error or problem

Views

53

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 16, 2020 0
Adobe Community Professional ,
Feb 16, 2020

Copy link to clipboard

Copied

It may also be your video driver on the new machine.  Version 10 may be so old to the operating system and video driver that they are causing you problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 16, 2020 0
New Here ,
Feb 18, 2020

Copy link to clipboard

Copied

Hi whsprague,

Thans for taking the time to reply.

After much experimentation & deliberation I have discovered that the SD card containing the video files is causing the problem. There is an intermittent fault on the camera's battery retaining clip and this has been the cause.

I'm not sure exactly what is happening but I have scrapped the camera and SD card and will start again with new kit.

As a matter of interest I am thinking of buying the latest edition of Premiere Elements (2020) but I am concerned it may be like starting all over again with the learning process. Do you know if it is similar enough to Premiere Elements 10 to be easy enough to learn?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2020 0
Adobe Community Professional ,
Feb 18, 2020

Copy link to clipboard

Copied

Adobe overhauled the interface of Premiere Elements with version 11, but I don't think you'll find a big learning curve. And most of the improvements have been for the better.

 

I have free Basic Training tutorials on YouTube that you may want to check out. They'll get you started.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2020 0
New Here ,
Feb 18, 2020

Copy link to clipboard

Copied

Hi Steve,

Thanks for the reply, I'll look into it.

Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2020 0