Highlighted

Premiere Elements 15 won't load - freezes and crashes

New Here ,
May 24, 2017

Copy link to clipboard

Copied

I downloaded Photoshop and premiere elements 15 in February and it has worked as expected until this week. I was working on a project Sunday - when I went back to continue working on it Tuesday, it wouldn't open the project. The Premiere elements program just shows it is loading (usually starts at somewhere between 60-80%) and then freezes and becomes unresponsive. I also tried starting a new project and the program becomes unresponsive. The only solution is to end the task.

I have uninstalled and reinstalled the program, and that didn't help. I have searched the forums and saw solutions about uninstalling Lavasoft Web Companion (which I confirmed I don't have) and updating graphics drivers (verified that there is no update available.) Frustrating to have an unusable product after only a few months

System Specs:

HP Spectre X360

Windows 10 Home 64-bit

Processor: Intel Core i5-7200U CPU @2.50GHZ

Graphics: Intel HD Graphics 620

RAM: 8.0 GB (7.88 usable)

Hard Drive 256GB SSD (79.1 GB used of 228GB usable)

Views

175

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Premiere Elements 15 won't load - freezes and crashes

New Here ,
May 24, 2017

Copy link to clipboard

Copied

I downloaded Photoshop and premiere elements 15 in February and it has worked as expected until this week. I was working on a project Sunday - when I went back to continue working on it Tuesday, it wouldn't open the project. The Premiere elements program just shows it is loading (usually starts at somewhere between 60-80%) and then freezes and becomes unresponsive. I also tried starting a new project and the program becomes unresponsive. The only solution is to end the task.

I have uninstalled and reinstalled the program, and that didn't help. I have searched the forums and saw solutions about uninstalling Lavasoft Web Companion (which I confirmed I don't have) and updating graphics drivers (verified that there is no update available.) Frustrating to have an unusable product after only a few months

System Specs:

HP Spectre X360

Windows 10 Home 64-bit

Processor: Intel Core i5-7200U CPU @2.50GHZ

Graphics: Intel HD Graphics 620

RAM: 8.0 GB (7.88 usable)

Hard Drive 256GB SSD (79.1 GB used of 228GB usable)

Views

176

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 24, 2017 0

Have something to add?

Join the conversation