Highlighted

Red Screen on Premiere Elements 18

New Here ,
Mar 04, 2018

Copy link to clipboard

Copied

Hi there,

I have just upgraded from Premiere Elements 14 to 18 becuase I bought a new camera (Panasonic Lumix G80/85). So I'm now recording video in 4k but I keep getting a red screen when editing video footage. Never used to get this using Elements 14, maybe because I'm now recording in 4k. There's is some mention of Unchecking "Enable accelerated Intel h.264 decoding" in Premiere Pro preferences but this option doesn't appear to be avaialble in Premiere Elements. I have checked I have my latest graphics driver (Intel(R) HD Graphics 4600) and beyond that I'm lost. Has anybody else experienced this and found a fix? Would be most grateful as Adobe support don't work on Sundays, understandably.

Adobe Community Professional
Correct answer by whsprague | Adobe Community Professional

I shoot 4K with a Panasonic GX8 and have no trouble editing it in Premiere Elements 2018.  It also worked with Premiere Elements 13!

In Premiere Elements there is a check box for hardware acceleration.  Go to Edit > Preferences > General. 

Untitled.jpg

Views

818

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Red Screen on Premiere Elements 18

New Here ,
Mar 04, 2018

Copy link to clipboard

Copied

Hi there,

I have just upgraded from Premiere Elements 14 to 18 becuase I bought a new camera (Panasonic Lumix G80/85). So I'm now recording video in 4k but I keep getting a red screen when editing video footage. Never used to get this using Elements 14, maybe because I'm now recording in 4k. There's is some mention of Unchecking "Enable accelerated Intel h.264 decoding" in Premiere Pro preferences but this option doesn't appear to be avaialble in Premiere Elements. I have checked I have my latest graphics driver (Intel(R) HD Graphics 4600) and beyond that I'm lost. Has anybody else experienced this and found a fix? Would be most grateful as Adobe support don't work on Sundays, understandably.

Adobe Community Professional
Correct answer by whsprague | Adobe Community Professional

I shoot 4K with a Panasonic GX8 and have no trouble editing it in Premiere Elements 2018.  It also worked with Premiere Elements 13!

In Premiere Elements there is a check box for hardware acceleration.  Go to Edit > Preferences > General. 

Untitled.jpg

Views

819

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 04, 2018 0
Adobe Community Professional ,
Mar 04, 2018

Copy link to clipboard

Copied

I shoot 4K with a Panasonic GX8 and have no trouble editing it in Premiere Elements 2018.  It also worked with Premiere Elements 13!

In Premiere Elements there is a check box for hardware acceleration.  Go to Edit > Preferences > General. 

Untitled.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2018 0
New Here ,
Mar 05, 2018

Copy link to clipboard

Copied

That worked, thank you :-). Much appreciated. I'm left with a stuttering preview but I think that might be more to do with the fact my PC is 3 years old and maybe not up to the task of editing 4k video footage. Good to get rid of the red screen though. Cheers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 05, 2018 0