Working on Adobe Premiere Elements 19 on iMac. I had a power surge then the play button won't work

New Here ,
Jan 19, 2020 Jan 19, 2020

Copy link to clipboard

Copied

I'm using Adobe Premiere Elements 19 on an iMac. I had a power surge, now the play button and the spacebar shortcut will not work.

 

I've also lost 2 days worth of work, even though Autosave is enabled. I was thinking about uninstalling and reinstalling the software, but the installation code is one time use. Is there a work around, or does anyone know the solution to my dilemma?

 

With Autosave enabled I would think that my files would be somewhere saved on my computer. Any ideas?

TOPICS
Account management, Activation, CC FAQ, Installation, Libraries, New user

Views

222

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 19, 2020 Jan 19, 2020

Copy link to clipboard

Copied

LATEST

Power surge sounds like a hardware problem, not software.  But, uninstalling and reinstalling won't hurt anything.

The serial number is NOT one time only.  

Look for a folder named "Adobe Premiere Elements Auto-Save".  There should be backups in it. 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines